Page 1 of 1

How do I play a video ...

Posted: Thu Dec 20, 2012 11:31 am
by conde
Why does the script in this Livecode lesson not work?

LS 5.5.3, SDKs: 5.1, 6.0, Simulator 5.1, 6.0

Re: How do I play a video ...

Posted: Thu Dec 20, 2012 12:03 pm
by Klaus
Hi conde,

what exactly does not work?
Could you please post your script(s), guessing is not an option 8)


Best

Klaus

Re: How do I play a video ...

Posted: Thu Dec 20, 2012 12:19 pm
by conde
Hallo Klaus,

the enclosed stack downloadable iOSNativeVideoLesson.zip is not working. It does not open in the simulator.

Gruß Guera

Re: How do I play a video ...

Posted: Thu Dec 20, 2012 12:31 pm
by Klaus
But opens in the IDE?

Re: How do I play a video ...

Posted: Thu Dec 20, 2012 12:47 pm
by Dixie
Conde...

The video lesson stack does work, I have just downloaded it and tried it... however, I can only get it to run in the 5.1 simulator ...

be well

Dixie

Re: How do I play a video ...

Posted: Thu Dec 20, 2012 1:01 pm
by conde
Klaus wrote:But opens in the IDE?
Yes with an error in card 1002, line 3
Dixie wrote:Conde...
The video lesson stack does work, I have just downloaded it and tried it... however, I can only get it to run in the 5.1 simulator ...
Dixie
Yes - only in 5.1 but the video does not appear. Only Loading ...

Re: How do I play a video ...

Posted: Thu Dec 20, 2012 1:14 pm
by Dixie
Conde...

I get no error. .. It loads, it runs.. I do admit that the loading takes longer than I remember it doing when I first ran this with, I think liveCode 4.6.4. I am running Mountain Lion, liveCode 5.5.3 and xCode 4.5.2 on a MacBook Pro

be well

Dixie

Re: How do I play a video ...

Posted: Thu Dec 20, 2012 1:16 pm
by Klaus
conde wrote:
Klaus wrote:But opens in the IDE?
Yes with an error in card 1002, line 3
...
Ah, yes, loaded the stack and took a look.

Unfortunately most of the Livecode examples lack a lot of basics (not to say they suck :D ), like these lines in an "iOS" stack:

Code: Select all

on opencard
   if the environment <> "mobile" then
      exit opencard
   end if
## special iOS stuff here like: iPhonecontrolThisAndThat...
Without these lines this will throw an error in the IDE, big fun!

Re: How do I play a video ...

Posted: Thu Dec 20, 2012 1:30 pm
by conde
Thanks Klaus,
now it works in IDE. But in Simulator 5.1 I see no video and in 6.0 the app crashes.

Is it true that there is no workaround to play a video with player control in 6.0 ? :o I'm trying since yesterday, nothing works. :(

Re: How do I play a video ...

Posted: Thu Dec 20, 2012 2:00 pm
by Klaus
Hi conde,

sorry, no idea!
I do not have any mobile license nor do I develop for mobile.


Best

Klaus

Re: How do I play a video ...

Posted: Thu Dec 20, 2012 2:12 pm
by Dixie
The video won't play in the IDE using the supplied script, as you can't use iOS controls in the IDE !
The video plays in the 5.1 simulator
The video does not play in the 6.0 simulator
The stack runs on a device, if you create the standalone, running iOS 6.0.1

Re: How do I play a video ...

Posted: Thu Dec 20, 2012 2:26 pm
by conde
Okay Dixie - thanks. It’s clear as daylight.