Horizontal X-Axis Labels

Get help and support using chartsEngine for LiveCode.

Moderators: heatherlaine, BvG

Post Reply
ronn
Posts: 24
Joined: Sun Apr 09, 2006 6:14 pm

Horizontal X-Axis Labels

Post by ronn » Sun Mar 01, 2009 9:25 pm

Hi Malte.

Great tool! I'm playing around with generating a histogram for which the x-axis labels should be horizontal. I've set the "gridXDescriptionOrientation" to "Normal" and the labels that show, do show horizontally, but most of the labels are missing.

For example, if my distribution had columns for 10,25,50,100,250, with a left or right orientation all labels show as advertised. But with a "normal" orientation all columns show but only the 10 and 25 labels -- the 10 below the middle column and the 25 below the last column.

Is this a known problem you'll fix in a later version or is it just me doing something dumb? Thanks for any info.

... Ron

BTW, a great add-on for a future version (yeah, I know; we're never satisfied) would be an option to automagically include a data table below line & column charts as in Excel.[/i]

malte
Posts: 1098
Joined: Thu Feb 23, 2006 8:34 pm
Location: Ostenfeld germany
Contact:

Post by malte » Sun Mar 01, 2009 10:48 pm

Hey Ron,

could you send me your stack off list, or post a snapshot + script and data? If the gridXDescriptionOrientation has an influence on the amount of labels being drawn this smells like a bug somewhere.

Cheers,

Malte

ronn
Posts: 24
Joined: Sun Apr 09, 2006 6:14 pm

Post by ronn » Mon Mar 02, 2009 12:59 am

Thanks Malte. I'll send you the stack.

... Ron

malte
Posts: 1098
Joined: Thu Feb 23, 2006 8:34 pm
Location: Ostenfeld germany
Contact:

Post by malte » Mon Mar 02, 2009 8:56 am

Hi Ron,

thanks for sending. There appears to be a bug with the labeling routine. I'll be travelling till wednesday, but will see to get that fixed ASAP.

Cheers,

Malte

malte
Posts: 1098
Joined: Thu Feb 23, 2006 8:34 pm
Location: Ostenfeld germany
Contact:

Post by malte » Wed Mar 11, 2009 8:27 am

Hey Ron,

just to keep you updated. I am about to having this fixed by the end of the week latest I hope. Once that fix is implemented I will upload a version to test.

Cheers,

Malte

malte
Posts: 1098
Joined: Thu Feb 23, 2006 8:34 pm
Location: Ostenfeld germany
Contact:

Post by malte » Sun Jul 12, 2009 8:56 pm

Hey ron,

I am terribl sorry. I really thought I had fixed the issue in 1.0.4, however it turned out I did not. After giovanni has pinged me here it should now be fixed.

http://derbrill.de/downloads/chartsEngine_105.zip

Please let me know if this one works for you.

Please excuse the long wait. All the best,

Malte

ronn
Posts: 24
Joined: Sun Apr 09, 2006 6:14 pm

Post by ronn » Sun Jul 12, 2009 10:44 pm

Ta Da! It works just as advertised now Malte. Your timing is great since I now need that feature again. Thanks.
... Ron

Bill Pittman
Posts: 6
Joined: Sun Jul 23, 2006 9:57 pm

Re: Horizontal X-Axis Labels

Post by Bill Pittman » Thu Feb 25, 2010 10:28 pm

Hi,

I just bought chartsEngine and I'm trying to complete a stacked bar chart. It works fine until I try to add date labels to each stacked bar. I'm not sure what I'm doing wrong: here is the error:

error: 379,2357,82
465,2357,1
253,2352,1
253,2257,1
253,2227,1
253,2165,1
Hint: chartsCreateGridX

I convert the short date to seconds before saving the data. I did not find a reference to [createGridX] in the docs. Any help would be appreciated.

Here is the bar chart script:

local tChart, tData, tLegend, tColor
set the defaultStack to "stackA"
if exists(group "nr1") then
delete group "nr1"
end if
--
if exists(group "nr1_legend") then
delete group "nr1_legend"
end if
--
chartsCreateChart "nr1", 42,160,775,552
put the result into tChart
-- put the long id of group "nr1" into tChart
-- set the itemdel to tab
--
put the long id of grp "nr1" into tChart
set the charts["data"] of tChart to field "A" of card "B" of stack "C"
set the charts["dataIncludesX"] of tChart to "true"
set the charts["xConvertsTo"] of tChart to "short date"
set the charts["chartItemdel"] of tChart to tab
--
put 255 & comma & 78 & comma & 0 & return after tColor
put 255 & comma & 165 & comma & 32 & return after tColor
put 215 & comma & 243 & comma & 67 & return after tColor
put 76 & comma & 181 & comma & 36 after tColor
set the charts["chartColors"] of tChart to tColor
--
set the charts["showLegend"] of tChart to "true"
set the charts["legendNames"] of tChart to "A" & return & "B" & return & "C" & return & "D"
set the loc of the chartsLegendId of tChart to 684,145
--
set the charts["caption"] of tChart to "My First Stacked Bars"
set the charts["captionTextsize"] of tChart to 18
--
set the charts["showGridXDescription"] of tChart to "true"
set the charts["gridYFill"] of tChart to "true"
set the charts["barsDistance"] of tChart to 20
set the charts["gridX"] of tChart to 1
set the charts["chartStyle"] of tChart to "barsStacked"
--
send "chartsRefresh" to tChart

malte
Posts: 1098
Joined: Thu Feb 23, 2006 8:34 pm
Location: Ostenfeld germany
Contact:

Re: Horizontal X-Axis Labels

Post by malte » Fri Feb 26, 2010 11:25 pm

Hi Bill,

just a quick reply to let you know I´ve seen your post. I just returned from a 2 days business travel without iNet access. I will look into this as soon as I had a bit of sleep. :-)

For the error hint: chartsCreateGridX is an internal handler, that sets up the x-Grid. I will have to look what is / was going wrong though.

All the best,

Malte

malte
Posts: 1098
Joined: Thu Feb 23, 2006 8:34 pm
Location: Ostenfeld germany
Contact:

Re: Horizontal X-Axis Labels

Post by malte » Sun Feb 28, 2010 7:59 pm

Hi Bill,

could you please send me your stack off list to info@derbrill.de?
I will need to see the data you want to display.

Thanks,

Malte

malte
Posts: 1098
Joined: Thu Feb 23, 2006 8:34 pm
Location: Ostenfeld germany
Contact:

Re: Horizontal X-Axis Labels

Post by malte » Mon Mar 01, 2010 10:06 pm

Uploaded 1.0.8 to fix the problem.

http://derbrill.de/downloads/chartsEngine_108.zip

Post Reply

Return to “chartsEngine”