Rev. Leg. stack to Mac 0S9 Standalone

Want to move your code and projects to LiveCode but don't know where to start?

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller

Post Reply
maxs
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 402
Joined: Sat Jun 24, 2006 12:02 am
Contact:

Rev. Leg. stack to Mac 0S9 Standalone

Post by maxs » Mon Feb 04, 2008 10:23 pm

I need help converting a Rev stack, saved as a Legacy stack , into a Mac Standalone ( 68k or Universal ) which will work under OS 9.

I've had endless problems trying to do this simple conversion. Has anyone had success, and be willing to do this for me, if I email the file to you? It's a 3.5 MB file, I just need to be saved as standalone for OS 9.

Thank Max (323) 666-6723 or max7@aol.com

Mark
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 5132
Joined: Thu Feb 23, 2006 9:24 pm
Contact:

Post by Mark » Mon Feb 04, 2008 11:33 pm

I Maxs,

I don't mind helping you out, but first I'd like to know which problems you encounter.

Best,

Mark
The biggest LiveCode group on Facebook: https://www.facebook.com/groups/livecode.developers
The book "Programming LiveCode for the Real Beginner"! Get it here! http://tinyurl.com/book-livecode

maxs
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 402
Joined: Sat Jun 24, 2006 12:02 am
Contact:

Conversion

Post by maxs » Tue Feb 05, 2008 9:11 am

Hi Mark,

When I go to build a standalone, It requests a 68k engine, and offers to download one. When I click OK, It gives me an error message, and the buld cancels.

Any ideas. Thanks for offering to give a hand. Max

Mark
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 5132
Joined: Thu Feb 23, 2006 9:24 pm
Contact:

Post by Mark » Tue Feb 05, 2008 10:27 am

Dear Max,

Do you really want to build for 68K machines? Can't you simpy turn this off and build for Mac OS X?

You will find engines for many, but not all, versions of Revolution in: ftp://ftp.runrev.com/pub/revolution/downloads/engines/

Let me know whether this solves it.

Best,

Mark
The biggest LiveCode group on Facebook: https://www.facebook.com/groups/livecode.developers
The book "Programming LiveCode for the Real Beginner"! Get it here! http://tinyurl.com/book-livecode

maxs
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 402
Joined: Sat Jun 24, 2006 12:02 am
Contact:

Post by maxs » Wed Feb 06, 2008 12:42 am

Hi Mark,

Thanks for the engines info. I added a Fat and a regular engine to the engine folder. (They have .dir extentions)

Revolution does not recognize them, and the same error message happens. I don't know why.

Max

Mark
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 5132
Joined: Thu Feb 23, 2006 9:24 pm
Contact:

Post by Mark » Wed Feb 06, 2008 12:49 am

Hi Max,

Which version of Rev are you using?

Mark
The biggest LiveCode group on Facebook: https://www.facebook.com/groups/livecode.developers
The book "Programming LiveCode for the Real Beginner"! Get it here! http://tinyurl.com/book-livecode

maxs
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 402
Joined: Sat Jun 24, 2006 12:02 am
Contact:

Post by maxs » Wed Feb 06, 2008 2:20 am

I'm using Rev 2.6.1, as are the engines I downloaded. (I'm thinking that the .dir extentions mean that I need to further decompress those files in some way.

Thanks for keeping up.

Mark
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 5132
Joined: Thu Feb 23, 2006 9:24 pm
Contact:

Post by Mark » Wed Feb 06, 2008 12:04 pm

Hi Maxs,

When you download an engine, you get a file with the extension gz. You have to decompress this file. You can simply delete the "dir" extension.

Now I have found a problem here. The Mac OS X engine available on the FTP server is really just the engine, but in the engines folder of my Revolution for Mac OS 9, there is a complete application package that includes a contents directory, plist file etc. etc etc.

I downloaded the engines a long time ago and didn't need the FTP site for the Mac OS X engine. If you need the Mac OS X engine, you should probably ask Rev support for it. If support can't provide you with an engine, feel free to send me an e-mail.

Now I have just tried to download all engines from within Rev 2.6.1 on Mac OS 9 and Mac OS X. I can download all engines, except Unix-SPARC and Mac 68K. Apparently, someone decided that the old Unix engines should be available to Rev 2.6.1, as I don't believe that one could download these engines within Revolution previously.

One might put the Unix-SPARC engine of Rev 2.2.x into the 2.6.1 engines folder, if one prefers. To be able to build 68K applications, I simply duplicated the Fat engine and called it MacOS68K. Not that this doesn't make much sense, but if you want to be as complete as possible it is an option.

Now that I am thinking at all over and remember how I dealt with the problem in the past, I wonder, why don't you simply disable the 68K build? Just make standalones for PPC and Fat and forget about 68K.

Just out of curiousity, do you think you are actually going to use your standalone on an 68K machine?

Best,

Mark
The biggest LiveCode group on Facebook: https://www.facebook.com/groups/livecode.developers
The book "Programming LiveCode for the Real Beginner"! Get it here! http://tinyurl.com/book-livecode

Janschenkel
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 977
Joined: Sat Apr 08, 2006 7:47 am
Location: Aalst, Belgium
Contact:

Post by Janschenkel » Wed Feb 06, 2008 1:29 pm

Hi Mark et al,

If my memory serves me well, Mac68K was dropped with the release of Revolution 2.5 - the reasoning being that the last non-PowerPC Mac had stopped shipping 10 years prior. RunRev's resources were better spent on updating the other platforms at that point.
Given the lack of complaints, I'd say this was the right decision. Of course, updating the standalone builder to reflect this, would also have been a good idea.

Jan Schenkel.
Quartam Reports & PDF Library for LiveCode
www.quartam.com

maxs
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 402
Joined: Sat Jun 24, 2006 12:02 am
Contact:

OS9 build

Post by maxs » Wed Feb 06, 2008 6:11 pm

Hi Steve,

My school, (as many, if not most, elementary schools) is still running imacs with system OS9.

My math program, which I spent a year writing, will not work on them, unless I can get a OS9 build.

Although I appreciate all you time and effort helping me, I'm still at square one, and don't know what to do. Perhaps if I can email the pre-standalone to someone who is able to make a standalone in OS9, I would think I would be very easy for them to do.

Thanks, Max

Mark
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 5132
Joined: Thu Feb 23, 2006 9:24 pm
Contact:

Post by Mark » Wed Feb 06, 2008 6:17 pm

Steve? Who's Steve? :-)

As I said, you can send me the stack, if eveything else fails. I'd expect you will want to make standalones more than once, so you might want to figure out why you are unable to build standalones. I bet turning off the 68K option does the trick for you.

Best,

Mark
The biggest LiveCode group on Facebook: https://www.facebook.com/groups/livecode.developers
The book "Programming LiveCode for the Real Beginner"! Get it here! http://tinyurl.com/book-livecode

Janschenkel
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 977
Joined: Sat Apr 08, 2006 7:47 am
Location: Aalst, Belgium
Contact:

Post by Janschenkel » Thu Feb 07, 2008 1:02 pm

For iMacs running MacOS 9, you don't need Mac68K - that's for really, really old Macs that shipped before 1994. An iMac has at least a PowerPC G3 processor.
So building a standalone for MacPPC (PowerPC) should do the trick.

Jan Schenkel.
Quartam Reports & PDF Library for LiveCode
www.quartam.com

Post Reply

Return to “Converting to LiveCode”