RevMobile

Create fast, sprite powered games with Animation Engine, co-developed with DerBrill Software!

Moderators: heatherlaine, robinmiller, kevinmiller, malte

ToreT
Posts: 14
Joined: Sat Jan 27, 2007 8:41 pm
Location: oslo

RevMobile

Post by ToreT » Wed Mar 17, 2010 7:57 pm

I am wondering if AnimationEngine will be possible to use with RevMobile?

malte
Posts: 1098
Joined: Thu Feb 23, 2006 8:34 pm
Location: Ostenfeld germany
Contact:

Re: RevMobile

Post by malte » Wed Mar 17, 2010 10:31 pm

Hi Tore,

I am currently using it with the pre alpha. There will need to be some minor adaptions needed to be made on my end, however as far as I can see most of ae is just working. What is known to not work (yet) are the constraining handlers. The rest just works fine.

All the best,

Malte

ToreT
Posts: 14
Joined: Sat Jan 27, 2007 8:41 pm
Location: oslo

Re: RevMobile

Post by ToreT » Thu Mar 18, 2010 8:41 pm

Thanks, that brakes down a few boundaries for what I can imagine possible with revMobile, however I'm curious to know if it will be a strict limitation regarding memory and speed?

malte
Posts: 1098
Joined: Thu Feb 23, 2006 8:34 pm
Location: Ostenfeld germany
Contact:

Re: RevMobile

Post by malte » Fri Mar 19, 2010 1:58 pm

Reposting, because in recreating the forums my answer got lost.

Performance on the iPhone simulator is excellent. I compiled a game that makes heavy use of AE and (at least in the simulator) it behaves just like the desktop version. I will need to test on a real device though. For Win mobile things are a little different. There it will depend heavyly on the device that is running the app. My first simulator tests where somewhat disappointing, though the emulator I´ve been using emulates a 300MHz device as far as I know. Also I was running the emulator in a virtual machine running VISTA on my Mac. Not much to expect there I guess.


Cheers,

malte

ctflatt
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 243
Joined: Sun Dec 06, 2009 12:24 am
Location: Fredericktown, MO
Contact:

Re: RevMobile

Post by ctflatt » Fri Oct 08, 2010 11:49 pm

Malte:

I cannot figure out how to get the AE3 resources to work in iPhone Simulator. AE works in runtime, but when testing with revMobile plug-in, cannot get the same functionality.

Can you help? I don't know the right questions to ask to figure this out.

Any help would be greatly appreciated.

:Christopher

malte
Posts: 1098
Joined: Thu Feb 23, 2006 8:34 pm
Location: Ostenfeld germany
Contact:

Re: RevMobile

Post by malte » Wed Oct 13, 2010 7:55 pm

Hi Christopher,

sorry for the late reply. Things got a little messy over here with a dead HD and backup system (HD died while writing to the backupsystem. No fun at all)

Anyways. For mobile:

For now I recommend making ae a substack of your main stack:

in the messagebox:

set the mainstack of stack animationEngine to "nameOfYourStackHere"

then in your mainstack

on openstack
start using stack "animationEngine"
pass openstack
end openStack

Now you should be set.

All the best,

Malte

ctflatt
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 243
Joined: Sun Dec 06, 2009 12:24 am
Location: Fredericktown, MO
Contact:

Re: RevMobile

Post by ctflatt » Fri Oct 15, 2010 3:58 pm

Malte:

Sorry to hear about the HD... but thanks for the response.

I did as you instructed, and my build works in LiveCode 4.5, but when viewed in the iPad simulator, no AE works.

I used a simple build of 2 cards, a button on each. First card, button takes you to card 2. Second card, button should aeFadeIn over 2000, take you to card 1.

The aeFadeIn does not work with this script in card 2:

on openCard
aeFadeIn the long ID of btn "back",2000
end openCard

Again, this works in the LiveCode IDE, but not iPad simulator...

Do I have to include AE in the files portion of the mobile development plugin?

I am at a loss.

If you have the time, could you guide me in the right direction, again?

Thanks!

malte
Posts: 1098
Joined: Thu Feb 23, 2006 8:34 pm
Location: Ostenfeld germany
Contact:

Re: RevMobile

Post by malte » Fri Oct 15, 2010 6:05 pm

Just downloading xCode to the newly setup machine. I´ll post as soon as I know more.

ctflatt
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 243
Joined: Sun Dec 06, 2009 12:24 am
Location: Fredericktown, MO
Contact:

Re: RevMobile

Post by ctflatt » Fri Oct 15, 2010 9:22 pm

Thanks, Malte!

Looking forward to hearing from you.

malte
Posts: 1098
Joined: Thu Feb 23, 2006 8:34 pm
Location: Ostenfeld germany
Contact:

Re: RevMobile

Post by malte » Fri Oct 15, 2010 10:17 pm

Ok,

just a couple of hours later XCode finally installed... (Wow. 2.5 gigs, I forgot it was so big)

I successfully ran a demo using aeFadeIn

What I did

opened animationEngine in the IDE
created a stack
set the name of the stack to "myStack"
opened the messagebox
typed

Code: Select all

set the mainStack of stack "animationEngine" to "myStack"
in the stack created a button

script:

Code: Select all

on mouseUp
   start using "animationengine"
   aeFadeIn the long ID of me,2000
end mouseUp
saved stack "myStack"
opened the mobile plugin
ran in the simulator.Worked fine.

Hope that helps,

Malte

ctflatt
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 243
Joined: Sun Dec 06, 2009 12:24 am
Location: Fredericktown, MO
Contact:

Re: RevMobile

Post by ctflatt » Fri Oct 15, 2010 10:20 pm

Malte:

I was able to get the button to fade on card 2. Thanks for your help!

I want to try to simulate a page slide next using a swipe gesture. I don't think gestures are supported yet, but even a tap would suffice. Would I use aeMoveTo? I'm trying to get a pushLeft/pushRight type of visual effect, since these aren't supported yet on the platform.

Thanks, again, for your help.

BTW, do you have a PayPal donation setup for all of this help?

malte
Posts: 1098
Joined: Thu Feb 23, 2006 8:34 pm
Location: Ostenfeld germany
Contact:

Re: RevMobile

Post by malte » Sat Oct 16, 2010 11:04 am

Glad it works. I´m here to help

Regarding donations: Well, in the first place you bought the library. If you buy stuff from me I feel obliged to give as much support as I can. And I am really happy it is being used! It would be horrible to write stuff that just catches dust on other peoples HardDisks. :-)

That said, if someone feels like making a donation I won´t say no, but please do not feel like you have to.

You can use PAYPAL and send to info@derbrill.de

All the best,

Malte

ctflatt
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 243
Joined: Sun Dec 06, 2009 12:24 am
Location: Fredericktown, MO
Contact:

Re: RevMobile

Post by ctflatt » Wed Oct 27, 2010 10:07 pm

Malte:

First, I'm glad AE3 is working on my iPad... thanks for helping!

I do have another question, though.

Can you recommend a way to get better frame rates on the mobile device? For the interface I'm prototyping, the movement is a bit jerky.

Any suggestions would be most welcome, as always.

Thanks!

:Todd

malte
Posts: 1098
Joined: Thu Feb 23, 2006 8:34 pm
Location: Ostenfeld germany
Contact:

Re: RevMobile

Post by malte » Thu Oct 28, 2010 8:55 am

Hey Todd,

I would need to see code to make any recommendations. I must admit I did not test yet on an actual device. My tests so far all have been in the simulator, though I doubt that is really something you can rely on.

Cheers,

Malte

ctflatt
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 243
Joined: Sun Dec 06, 2009 12:24 am
Location: Fredericktown, MO
Contact:

Re: RevMobile

Post by ctflatt » Sat Oct 30, 2010 4:41 pm

Malte:

Here is a link to the stack I'm creating to learn both rev and ae... "learn" may be too ambitious, but I'm trying.

http://ctfinteractive.on-rev.com/projec ... _malte.zip

The scripts are working great in Rev and Simulator, but are a bit jerky on the device.

Any info you have would be appreciated.

:Todd

Post Reply

Return to “Animation Engine”