AE with LC6.5

Create fast, sprite powered games with Animation Engine, co-developed with DerBrill Software!

Moderators: heatherlaine, kevinmiller, robinmiller, malte

AE with LC6.5

Postby DRJ-UK » Tue Dec 10, 2013 8:34 pm

Malte

AE is a great extension to LC and has some really skillful coding to produce the smooth transitions. :D

I built an iPad App using LC 6.1.3 and AE animation was smooth and effective when tested on on an iPad (retina). However, when building exactly the same App with LC 6.5 the animations were rather erratic and not at all smooth on the same device. :( It seemed as if LC was generating some timing issues for AE animation.

Is this something you have noticed.

Dave
LiveCode: Versions 8.0, 8.1
Xcode: Version 7.3, 8.0
Mac OS X: 10.11.12 (macOS Sierra) on iMacs with 3.4 Intel Core i7 & 16GB Memory

Creating Apps for educational professionals, effective teaching and learning.
DRJ-UK
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
 
Posts: 73
Joined: Tue Aug 23, 2011 2:50 pm
Location: United Kingdom

Re: AE with LC6.5

Postby malte » Wed Dec 11, 2013 2:13 pm

Hi Dave,

not yet, though this sounds like a regression the runRev people would like to know about. Could I ask you to report this to quality.runrev.com?

All the best,

Malte
malte
 
Posts: 1096
Joined: Thu Feb 23, 2006 8:34 pm
Location: Ostenfeld germany

Re: AE with LC6.5

Postby DRJ-UK » Fri Dec 13, 2013 12:03 pm

Malte

Sorry for the delay getting back. Will report this as you suggest but thought you would want to be aware first.

Will build a demo stack with a visible timer and key variables displayed to retest and then forward to the RR team.

Dave
LiveCode: Versions 8.0, 8.1
Xcode: Version 7.3, 8.0
Mac OS X: 10.11.12 (macOS Sierra) on iMacs with 3.4 Intel Core i7 & 16GB Memory

Creating Apps for educational professionals, effective teaching and learning.
DRJ-UK
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
 
Posts: 73
Joined: Tue Aug 23, 2011 2:50 pm
Location: United Kingdom

Re: AE with LC6.5

Postby DRJ-UK » Fri Dec 13, 2013 1:33 pm

Malte

An update.

Built a simple stack with a small PNG image (200x100) to animate using the aeMoveTo command. In the script, acceleratedRendering is set true. Included buttons to set the iphoneSetRedrawInterval to either 0 (off) or 1 (refresh on iOS request).

Testing with a LC 6.1.3 build on an iPad device performs as expected, with iphoneSetRedrawInterval 0 more fluid than iphoneSetRedrawInterval 1 (as expected). When built and tested with LC 6.5.0, there is a slight difference (perceptively not quite as fluid compared to the LC 6.1.3 build)) with iphoneSetRedrawInterval 1.

In both cases the animation effect is completed in the time specified in asMoveTo.

Based on the test stack not sure whether this is worth reporting though. What it has revealed is the need to ensure iphoneSetRedrawInterval 0 is used for iOS builds before an aeMoveTo is implemented (expect this to be similar with other AE commands).

Will look again at the App we are working on to see if there is anything else.

Dave

Dave
LiveCode: Versions 8.0, 8.1
Xcode: Version 7.3, 8.0
Mac OS X: 10.11.12 (macOS Sierra) on iMacs with 3.4 Intel Core i7 & 16GB Memory

Creating Apps for educational professionals, effective teaching and learning.
DRJ-UK
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
 
Posts: 73
Joined: Tue Aug 23, 2011 2:50 pm
Location: United Kingdom


Return to Animation Engine

Who is online

Users browsing this forum: No registered users and 1 guest