Page 1 of 1

Big problem on object FIELD

Posted: Mon Feb 15, 2010 10:37 am
by ale870
Hello,
I usually work either on Windows or on Linux, and I discovered a big problem on Linux version: component FIELD, in Windows works perfectly, but on Linux it is really SLOOOW!
I make some tests using the same computer (so the problem is not related to hardware capabilities).
On Linux I have tried:
Linux Mint 8, Linux Ubuntu 9.04, Linux XFCE (similar results).

The problem is very big for me, since a FIELD component can be used to insert any kind of text.
This problem is not so evident when one uses FIELD as a single line, but the problem arise when I use the component to insert a multiline text. I don't need to insert a long text: even if I insert, for example, 50 lines, when I write via keyboard I notice an evident delay from when I press the key and when I see the letter on the screen, furthermore there is an evident delay when I use arrow-keys on the keyboard to scroll text (I go with the caret on top or bottom of the field and I start to scroll text).

Please note that other applications (a typical text editor like gedit, or scite, etc...) work VERY well, even with big text.

I think this is a problem related to optimization problems for RunRev executable in Linux. Please make some checks and try to fix this problem, since this is not the first time there are some big differences between Win, Mac and OSX, and this is a potential problem for a great development tool that uses cross-platform as a key-feature of the product self.

In this point-of-view, I understand that RunRev better support the most popular OS, but I think issues like this are very serious, even more thinking to the new products related to mobile systems: can I think that you apply the same policy for mobile devices (iPhone, Win, Maemo)?

Thank you.

Re: Big problem on object FIELD

Posted: Mon Feb 15, 2010 5:53 pm
by grzkmo
Hi ale870,

no problem with fields here on Ubuntu 9.10 64bit/gnome using rev 4.0.

What's your version of rev?

best,

grzkmo

Re: Big problem on object FIELD

Posted: Mon Feb 15, 2010 6:16 pm
by ale870
I use Linux Mint (gnome) - 32bit, with Runtime Revolution 4.0.
Even the code editor seems really slow, so I think the problems are "connected".
I'm working on a notebook HP EliteBook 6930p, with 3GB Ram, and Intel 4 series as video card.

Re: Big problem on object FIELD

Posted: Mon Feb 15, 2010 8:28 pm
by grzkmo
I just installed Linux Mint 8 in a virtual machine (vbox) and tested rev.
I put 10000 lines in a scrolling field and went to the last line and edited some lines. All ok. Fast!

Did you a check with ldd (cd to your rev dir and ldd revolution). All dependencies ok?

I remember I had problems with field and the editor in rev 3.0 or 3.5.

In 4.0 it's ok.


Grzkmo

Re: Big problem on object FIELD

Posted: Tue Feb 16, 2010 12:50 am
by ale870
Thank you for the suggestion, I will check it!

Re: Big problem on object FIELD

Posted: Tue Feb 16, 2010 2:37 pm
by ale870
Sorry, can you send me hardware configuration of your computer where you tried to execute Linux?
I think one problem could be related to video card performance. I have a notebook with a "small" video card (not so fast).
I have an Intel 4 series (similar to intel 915 I think).

Thank you.