Page 2 of 2

Re: Unable to install LC 9 on Ubuntu 18.04

Posted: Mon Jul 09, 2018 5:22 pm
by bogs
Sorry, I must have been thinking of Max's post saying it just crashed :oops:

Re: Unable to install LC 9 on Ubuntu 18.04

Posted: Mon Jul 09, 2018 5:38 pm
by wsamples
bogs wrote:
Mon Jul 09, 2018 3:22 pm
I'm not sure the OP was trying to post FUD, it seems a relatively common post for anyone either new to linux or Lc in general, and even some old(er) timers, and I've seen (and answered) a number of posts just like it as have many others. I'm far more interested in the problem he posed, and whether it can be recreated or not.
Oh, I don't have any reason to believe the OP was being malicious and I absolutely agree that the best response is a solution to his problem. I'm sorry I couldn't offer that.

However, these comments are here for posterity and can contribute to FUD regardless of intent. That's a reality on the internet. I think it's especially unfortunate that people who should know better sometimes make this kind of careless statement, and I don't feel shy about reiterating this point, for the reason just stated. I don't mean for it to seem harsh or dismissive of real issues people might encounter. I have had some issues of my own with Livecode under Linux. I've mostly, but admittedly not always, been able to find solutions and try to share information when I have it.

:)

Re: Unable to install LC 9 on Ubuntu 18.04

Posted: Mon Jul 16, 2018 8:29 am
by jrs
Hello. I have the same issue to install 64bit LC7 to LC9 in ubuntu 18.04LTS i have tested it on two different computers with 64bit ubuntu 18.04LTS.

I have tried it with the sudo and chmod and all dipendencies i can think of.
The installation stops an telling me " Installer slave quit unexpectedly"

The only differens between LC7 and LC9 is that LC7 never stopps with this error it loops in the background (strace).

LC9 works fine on Ubuntu 64bit 16.04LTS and on 64bit Windows 10.

And its the same error in LC9.01RC1

Best regards Jimmy

Re: Unable to install LC 9 on Ubuntu 18.04

Posted: Mon Jul 16, 2018 3:37 pm
by bogs
Couple of questions.

Is this a fresh Ubuntu install, or older install updated to 18.04? What is the output of the terminal window when you use sudo to attempt the install?

Re: Unable to install LC 9 on Ubuntu 18.04

Posted: Tue Jul 17, 2018 7:03 pm
by jrs
Hello.
Its a upgrade from 17.04-64bit.

The output is this.
$sudo ./LiveCodeCommunityInstaller-9_0_0-Linux.x64
$LiveCodeCommunityInstaller-9_0_0-Linux.x64 exiting on signal 11

Best regards Jimmy
!!!
But now i problably found it. I sniffed the Kernel when i started the installation and i could see in the path.
/H..mtningar/ Its a swedish installation and it should be Hämtningar eg. Download so i copyed the LC9 installation to a folder without swedish characters and it worked.

16747107 20:27:35.175477065 0 LiveCodeCommuni (19836) < lstat res=-2(ENOENT) path=~root/.runrev/logs/livecode community_installer_log.txt(/home/jimmy/H..mtningar/~root/.runrev/logs/livecode community_installer_log.txt)

Best regards Jimmy

Re: Unable to install LC 9 on Ubuntu 18.04

Posted: Tue Jul 17, 2018 8:49 pm
by bogs
I hope panos sees this, but congrats on figuring it out.

Re: Unable to install LC 9 on Ubuntu 18.04

Posted: Tue Jul 17, 2018 9:46 pm
by LiveCode_Panos
Nice work Jimmy :)

Good to know that the installer does not like unicode cars in the filename, thanks.

Best,
Panos
--