Unable to install LC 9 on Ubuntu 18.04

Deploying to Linux? Get penguinated here.

Moderators: heatherlaine, Klaus, FourthWorld, robinmiller, kevinmiller

cfrussen
Posts: 2
Joined: Sat Jul 07, 2018 6:39 pm

Unable to install LC 9 on Ubuntu 18.04

Post by cfrussen » Sat Jul 07, 2018 6:57 pm

Hello,
I cannot install LiveCode 9 on Ubuntu 18.04. In both cases, install for all users or just me, the installer stops with the message:

The installation was not successful.
Installer slave quit unexpectedly.


I've added the 32bit support and installed the dependencies with "sudo apt-get install libgtk2.0-0:i386" but same error.

Any help?

ClipArtGuy
Posts: 205
Joined: Wed Aug 19, 2015 4:29 pm

Re: Unable to install LC 9 on Ubuntu 18.04

Post by ClipArtGuy » Sat Jul 07, 2018 7:45 pm

Have you tried one of MaxV's unofficial .DEB packages?

http://www.maxvessi.net/livecode/linux/

cfrussen
Posts: 2
Joined: Sat Jul 07, 2018 6:39 pm

Re: Unable to install LC 9 on Ubuntu 18.04

Post by cfrussen » Sat Jul 07, 2018 11:44 pm

Well... What a disappointment! The installation requires lot of unmet dependencies. I've tried to install them manually and I broke the Linux install :(

I've trashed the Ubuntu 18.04 install and reinstalled Windows as LC isn't working on latest Linux distros as I see, official or unofficial packages.

Too bad for Linux, now my son had to stick with Windows :(

ClipArtGuy
Posts: 205
Joined: Wed Aug 19, 2015 4:29 pm

Re: Unable to install LC 9 on Ubuntu 18.04

Post by ClipArtGuy » Sun Jul 08, 2018 1:31 am

Going back to windows seems a tad extreme. I can confirm that LC 9.0 is working here in Ubuntu 18.04, I don't recall having too much difficulty with the official download, so it's definitely possible.

bogs
Posts: 2282
Joined: Sat Feb 25, 2017 10:45 pm

Re: Unable to install LC 9 on Ubuntu 18.04

Post by bogs » Sun Jul 08, 2018 2:14 pm

cfrussen wrote:
Sat Jul 07, 2018 6:57 pm
I've added the 32bit support and installed the dependencies with "sudo apt-get install libgtk2.0-0:i386" but same error.
I am not sure why you would have installed this package with Lc 9, the only time I've found installing it necessary was with the 6 series down to 1.1. The only time you might need to install 32 bit libraries is if your installing 32 bit Lc on a 64 bit system, but since Lc comes in both flavors now, it really isn't necessary.

I do have some other questions, as I'd like to see if there is a problem with the installer as you mention.
  1. You don't mention if you were using Ubuntu x86 or x64.
  2. Which of the 2 Lc installers were you using?
  3. It appears implied you are using a fresh install of Ubuntu, but you don't say so specifically, was it a new install or did you update to it or what?
If you can provide the answers, I can run some tests to see if there are issues and how to resolve them. For now, I am just downloading a generic image of Ubuntu 18.04 and will run the 9 installer for it to see if there are any hiccups.
Image

bogs
Posts: 2282
Joined: Sat Feb 25, 2017 10:45 pm

Re: Unable to install LC 9 on Ubuntu 18.04

Post by bogs » Sun Jul 08, 2018 3:20 pm

Well, in the last 1 hour, I downloaded and installed a fresh Ubuntu 18.04 image. I didn't bother to update it. I then downloaded and installed the top Lc 9 stable image. Both were the 64 bit variants. Here is what I noticed.

The Lc exe. had to be marked executable (expected, varies from distro to distro).

During installation, the installer correctly stated that if installing for all users, admin privileges would be required, but then did not put up the dialog asking for the password as has been the case in the past. Using 'sudo' at the start of the installation resolved this, but should not be required.

Re-installed Ubuntu to test the 'install for user only' option. No issue noticed, install went through. However in both this attempt and the one previously attempted, at the end of the installer where it asks if you want to launch Lc, the program just quit.

I've seen this behavior vary again from distro to distro, with the distros not specifically supported having the most likelihood of launching Lc after an installation. Not a huge problem, but certainly not expected behavior.

At no time during either install were any other dependencies required to be downloaded outside of the installation of Ubuntu. Lc started and ran as expected. Both Ubuntu installations were the minimal install as well (first time I have seen that option in the Ubuntu installer, and was testing it as well). I did enable the 3rd party software, video codecs, etc.

If cfrussen chooses to come back and give some more details as to what their particular install attempt included, I'll be happy to give it another run duplicating it as closely as possible.
Image

ghettocottage
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 278
Joined: Tue Apr 10, 2012 9:18 am

Re: Unable to install LC 9 on Ubuntu 18.04

Post by ghettocottage » Sun Jul 08, 2018 4:30 pm

It has been my experience that at the end of installing LC, it asks if I want to launch it, it just quits. But then going and launching Livecode on my own after that works fine.

bogs
Posts: 2282
Joined: Sat Feb 25, 2017 10:45 pm

Re: Unable to install LC 9 on Ubuntu 18.04

Post by bogs » Sun Jul 08, 2018 7:51 pm

Yes, exactly as I said, and it does appear to depend on the distro to a great extent. For example, on antiX, it does actually launch instead of quitting, however antiX is not one of the supported distros. While you can certainly launch it after filling out the email bit thing, if your going to include a 'launch now' link, it should launch now, especially on a system it is theoretically specifically supported on, such as Ubuntu.
Image

wsamples
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 198
Joined: Mon May 18, 2009 4:12 am

Re: Unable to install LC 9 on Ubuntu 18.04

Post by wsamples » Mon Jul 09, 2018 5:11 am

bogs wrote:
Sun Jul 08, 2018 3:20 pm

During installation, the installer correctly stated that if installing for all users, admin privileges would be required, but then did not put up the dialog asking for the password as has been the case in the past. Using 'sudo' at the start of the installation resolved this, but should not be required.
This will depend on whether or not you've got gksu installed. Livecode needs that to give the installer elevated privileges. I had installed a Qt based alternative (with a link '/usr/bin/gksu') on my Antergos/KDE machine and for some reason that didn't work. Replacing that with the vanilla gksu package got it working.

I can't remember the last time I saw Livecode launch after installing because that box was checked. It's been some years :D I keep hoping...

I would like to dispute the assertion suggested by the OP that Livecode does not run on current Linux distros. I've run it successfully under various openSUSE versions including recent Leap and Tumbleweed releases. I currently run it on Antergos. I have tested it briefly on several other "unsupported" distros and find it runs well under almost all of them. In both openSUSE and Antergos using KDE Plasma, I haven't had any need to install anything in order to get it up and running, although to install for "All Users" one would have to install gksu as mentioned at the start of my comments here. My response doesn't help solve the OP's problem, and I don't know what to suggest, but it's not helpful to potential users to allow the propagation of FUD.

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 493
Joined: Fri Feb 06, 2015 4:03 pm

Re: Unable to install LC 9 on Ubuntu 18.04

Post by LiveCode_Panos » Mon Jul 09, 2018 8:39 am

Hi all,

See also this post from MaxV:

http://forums.livecode.com/viewtopic.ph ... 07#p168807

Best,
Panos
--

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 493
Joined: Fri Feb 06, 2015 4:03 pm

Re: Unable to install LC 9 on Ubuntu 18.04

Post by LiveCode_Panos » Mon Jul 09, 2018 12:41 pm

Hi folks,

Can you use the browser widget on Ubuntu 18.04 64 bit?

I get an error as soon as I drag it onto the stack from the Tools palette.

If it works for you, I might be missing a dependency.

Thanks,
Panos
--

MaxV
Posts: 1540
Joined: Tue May 28, 2013 2:20 pm
Location: Italy
Contact:

Re: Unable to install LC 9 on Ubuntu 18.04

Post by MaxV » Mon Jul 09, 2018 12:46 pm

cfrussen wrote:
Sat Jul 07, 2018 11:44 pm
Well... What a disappointment! The installation requires lot of unmet dependencies. I've tried to install them manually and I broke the Linux install :(

I've trashed the Ubuntu 18.04 install and reinstalled Windows as LC isn't working on latest Linux distros as I see, official or unofficial packages.

Too bad for Linux, now my son had to stick with Windows :(
Livecode 8 works well on Linux, Livecode 9 has some troubles.
To install 9, just use sudo:

Code: Select all

sudo ./LiveCodeComm...
The problem with 9 is the widget browser that crashes, if you don't use it, all good.

Please let me know what problem did you have with the unofficial packages, so I can find a solution. Is your Pc an old 32 bit system?
Livecode Wiki: http://livecode.wikia.com
My blog: http://livecodeitalia.blogspot.it
To post code use this: http://tinyurl.com/ogp6d5w

bogs
Posts: 2282
Joined: Sat Feb 25, 2017 10:45 pm

Re: Unable to install LC 9 on Ubuntu 18.04

Post by bogs » Mon Jul 09, 2018 3:22 pm

wsamples wrote:
Mon Jul 09, 2018 5:11 am
bogs wrote:
Sun Jul 08, 2018 3:20 pm

During installation, the installer correctly stated that if installing for all users, admin privileges would be required, but then did not put up the dialog asking for the password as has been the case in the past. Using 'sudo' at the start of the installation resolved this, but should not be required.
This will depend on whether or not you've got gksu installed. Livecode needs that to give the installer elevated privileges. I had installed a Qt based alternative (with a link '/usr/bin/gksu') on my Antergos/KDE machine and for some reason that didn't work. Replacing that with the vanilla gksu package got it working.
Agreed, however since gksu is not going to be included in the main supported linux distro anymore (for reasons stated elsewhere), that bit of the main installer may need to be re-written to accomodate. My only intention was to report what someone with a fresh install faced, and a work around to that issue.

In this case, the 2 solutions that don't require adding software appear to be either starting the installer with sudo, or installing only for the current user, but this does need to be fixed as neither is intuitive to someone just starting in.
I can't remember the last time I saw Livecode launch after installing because that box was checked. It's been some years :D I keep hoping...
I couldn't tell you why it works on different non supported distros, but that has been what I've found. I just find it odd it doesn't work at all on the main supported distro, but does work elsewhere :?
I would like to dispute the assertion suggested by the OP that Livecode does not run on current Linux distros. .... My response doesn't help solve the OP's problem, and I don't know what to suggest, but it's not helpful to potential users to allow the propagation of FUD.
I'm not sure the OP was trying to post FUD, it seems a relatively common post for anyone either new to linux or Lc in general, and even some old(er) timers, and I've seen (and answered) a number of posts just like it as have many others. I'm far more interested in the problem he posed, and whether it can be recreated or not.

From the fresh install on a fresh install of Ubuntu, it is obvious it can be installed on that distro, so we need more information from the OP as to the specific issues they encountered.
Image

bogs
Posts: 2282
Joined: Sat Feb 25, 2017 10:45 pm

Re: Unable to install LC 9 on Ubuntu 18.04

Post by bogs » Mon Jul 09, 2018 4:29 pm

LiveCode_Panos wrote:
Mon Jul 09, 2018 12:41 pm
Hi folks,
Can you use the browser widget on Ubuntu 18.04 64 bit?
I get an error as soon as I drag it onto the stack from the Tools palette.
If it works for you, I might be missing a dependency.
Thanks,
Panos
--
I don't think it is a dependency issue, here is the error it throws in a non-supported distro -
executing at 11:24:26 AM
LCB Error Value is not of correct type for assignment to variable - expected type <type: __builtin__.pointer> for assigning to variable tFactory in com.livecode.widget.browser.InitBrowserView
Object Browser
LCB File browser.lcb
LCB Line 471
Image

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 493
Joined: Fri Feb 06, 2015 4:03 pm

Re: Unable to install LC 9 on Ubuntu 18.04

Post by LiveCode_Panos » Mon Jul 09, 2018 4:53 pm

Hmm thanks bogs.

I get the same error.

Panos
--

Post Reply

Return to “Linux”