Player not working in Linux?

Deploying to Linux? Get penguinated here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Player not working in Linux?

Postby astroboy » Thu Oct 13, 2016 12:05 pm

Am I the only one with this issue?

I drag a player into a stack. When I try to open the Player's Property Inspector, LiveCode immediately crashes.

At first I thought it was some isolated issue in one computer, but soon I realized that it was happening in all my computers, 32 and 64 bits versions of LiveCode 8.0, so I thought that if I upgraded to 8.1, maybe the issue would be fixed. That didn't happen, the issue is still there.

When running LiveCode from a terminal, this is the error message left after crashing:

*** Error in `/home/linux/.runrev/components/livecodecommunity-8.1.0.x86/LiveCode Community.x86': free(): invalid pointer: 0x0be8a69f ***
astroboy
Livecode Opensource Backer
Livecode Opensource Backer
 
Posts: 28
Joined: Wed Apr 09, 2008 8:05 pm

Re: Player not working in Linux?

Postby mwieder » Thu Oct 13, 2016 5:59 pm

That's the way the player works/not works on linux.
It seems to work on LC7, so if this is a priority for you, you might try a recent LC7 build.
That broke in LC8 when the linux build moved to gdk.
Otherwise you can always shell out to vlc or some other media player.
mwieder
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
 
Posts: 2561
Joined: Mon Jan 22, 2007 7:36 am
Location: Berkeley, CA, US

Re: Player not working in Linux?

Postby astroboy » Fri Oct 14, 2016 12:13 pm

Thanks for your answer mwieder.

Well, I'm in shock to confirm that a basic feature (such being able to view the properties of a player) is not available for Linux users. That makes me feel like we're third class citizens in the LiveCode world, :cry:

Yes, there are workarounds, but a side result of them is that I would need to type more code than needed, and having to maintain different versions of the project, one for Linux -making it external calls to vlc or mplayer- and other with the normal use of a simple player, or working the project in an older version and then using an 8.x version to use the new features... eeeww!

Should I file a bug? I didn't find anything about it on the quality control center, so I wonder if the devs are even aware of it...
astroboy
Livecode Opensource Backer
Livecode Opensource Backer
 
Posts: 28
Joined: Wed Apr 09, 2008 8:05 pm

Re: Player not working in Linux?

Postby MaxV » Fri Oct 14, 2016 4:21 pm

On Livecode 7 player works very well, see https://www.youtube.com/watch?v=mxPzQaF-Feg
Just install mplayer
Livecode Wiki: http://livecode.wikia.com
My blog: http://livecodeitalia.blogspot.it
To post code use this: http://tinyurl.com/ogp6d5w
MaxV
 
Posts: 1282
Joined: Tue May 28, 2013 2:20 pm
Location: Italy

Re: Player not working in Linux?

Postby jacque » Fri Oct 14, 2016 6:44 pm

astroboy wrote:Yes, there are workarounds, but a side result of them is that I would need to type more code than needed, and having to maintain different versions of the project.


I agree that everything should work on Linux as it does everywhere else, but in the meantime you don't really need to maintain separate versions. Just branch the code:

Code: Select all
if the platform is "linux" then
-- do Linux thing
else
-- do player thing
end if
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com
jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
 
Posts: 3796
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN

Re: Player not working in Linux?

Postby astroboy » Fri Oct 14, 2016 7:57 pm

Jacque, It's a really good idea to branch the code in the way you showed.

But I'm still in shock that such a basic IDE function such as opening the Property Inspector for a Player is not available in Linux. Yes, I'm aware that I could do the same stuff I want to do with the player by typing in the Message Box instead of opening its Property Inspector. But it really feels awfully awkward to have to do a lot more work merely because of my choice of OS, and as a teacher, is not going to be awesome for the beginner students to have to type code to be able to do simple multimedia stuff just because they're on Linux...

Ok, enough tragic rant. I already opened a bug on the LiveCode Quality Control Center. http://quality.livecode.com/show_bug.cgi?id=18614
astroboy
Livecode Opensource Backer
Livecode Opensource Backer
 
Posts: 28
Joined: Wed Apr 09, 2008 8:05 pm

Re: Player not working in Linux?

Postby mwieder » Fri Oct 14, 2016 10:25 pm

astroboy-

Yes, absolutely agree. Thanks for filing the bug report - I *think* there's one in there already, but it won't hurt to have another in the system. The worst that will happen is that the new one will be declared a duplicate. And I think filing a new one shows that there's still interest in the issue. The dev team is well aware that player objects are nonfunctional on linux, but I don't think there's a lot of effort being put into getting this working. And I don't know enough about the gdk hooks to know where things broke or how to fix this up.
mwieder
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
 
Posts: 2561
Joined: Mon Jan 22, 2007 7:36 am
Location: Berkeley, CA, US

Re: Player not working in Linux?

Postby astroboy » Thu Dec 22, 2016 8:25 pm

I'm happy to report that this bug has been solved in the most recent stable version available to date, which is LiveCode 4.1.2. So Linux users can now enjoy the normal feature of opening the Property Inspector for their Players, as is usual in other OSes.
astroboy
Livecode Opensource Backer
Livecode Opensource Backer
 
Posts: 28
Joined: Wed Apr 09, 2008 8:05 pm


Return to Linux

Who is online

Users browsing this forum: No registered users and 2 guests