Not able to install LiveCode 8.0.0, Linux 32

Deploying to Linux? Get penguinated here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
astroboy
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 28
Joined: Wed Apr 09, 2008 8:05 pm

Not able to install LiveCode 8.0.0, Linux 32

Post by astroboy » Tue May 10, 2016 6:08 pm

The installation of LiveCode 8.0.0, Linux 64, all users, ran on my 64 bits system without any issue.

However, I cannot say the same of the Linux 32 Installer in a 32 bit system. After typing the admin password (required for the "All users" option), a dialog appear with the message: "Installer slave quit without eof". Downloaded two times the file just to be sure it wasn't a corrupted file. No luck.

It does install using the "You only" setup. Is it a bug reproducible for everyone?

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 5393
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: Not able to install LiveCode 8.0.0, Linux 32

Post by FourthWorld » Tue May 10, 2016 7:03 pm

I haven't run a 32-bit distro in some time, but last time I did this tip from Neil did the trick:
http://forums.livecode.com/viewtopic.ph ... 39#p104639

If that doesn't solve it for you you might try running it with ldd to see if there are any unmet dependencies.

Please report back to let us know how it goes.
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

astroboy
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 28
Joined: Wed Apr 09, 2008 8:05 pm

Re: Not able to install LiveCode 8.0.0, Linux 32

Post by astroboy » Thu May 12, 2016 12:11 pm

Hello

The suggested thread was not useful, since it refers to how to solve unmet dependencies for 64 bits systems.

I believe it's a bug on the 32 bit installer and not some unmet dependency, since it is able to finish without issues as "You only" setup, but it fails with the already mentioned message in the "All users" setup.

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 5393
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: Not able to install LiveCode 8.0.0, Linux 32

Post by FourthWorld » Thu May 12, 2016 11:09 pm

Well, it was helpful for me when I was using a 32-bit system. In your case the situation is indeed odd, since it works for "You Only" but not for "All Users". Are you running from an admin account? If so, you might want to file a bug report on that.
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

richmond62
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 1895
Joined: Fri Feb 19, 2010 10:17 am
Location: Bulgaria
Contact:

Re: Not able to install LiveCode 8.0.0, Linux 32

Post by richmond62 » Fri May 13, 2016 6:30 pm

Well, all I can say (and I realise is that it isn't very helpful) is that I installed
Livecode 8.0 "Stable" on Linux Mint 32-bit 17 without a backwards look.

Post Reply

Return to “Linux”