Livecode x64 7.0.6 installer not running..

Deploying to Linux? Get penguinated here.

Moderators: heatherlaine, Klaus, FourthWorld, robinmiller, kevinmiller

tasdvl9
Posts: 92
Joined: Fri Dec 06, 2013 3:55 am

Livecode x64 7.0.6 installer not running..

Post by tasdvl9 » Mon Jul 27, 2015 8:44 pm

Hello,

I'm trying to install the 7.0.6 version(LiveCodeInstaller-7_0_6-Linux.x64) of Livecode Commercial on my Linux Fedora 14 x86_64 system.
I've set the properties on the installer to 755 but when I double click on the .x64 installer it never gets executed.

Any ideas?

Thanks!

ghettocottage
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 250
Joined: Tue Apr 10, 2012 9:18 am

Re: Livecode x64 7.0.6 installer not running..

Post by ghettocottage » Mon Jul 27, 2015 9:13 pm

it needs to be set to executable. You may just be able to right-click>Properties>Permissions and check the box for "Allow executing file as program"

tasdvl9
Posts: 92
Joined: Fri Dec 06, 2013 3:55 am

Re: Livecode x64 7.0.6 installer not running..

Post by tasdvl9 » Mon Jul 27, 2015 9:29 pm

Thanks, tried that already as well. Setting the program to executable still doesn't invoke the installer when I double click it.

ghettocottage
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 250
Joined: Tue Apr 10, 2012 9:18 am

Re: Livecode x64 7.0.6 installer not running..

Post by ghettocottage » Mon Jul 27, 2015 10:20 pm

have you tried running it from the commandline? You can just right-click on the installer and copy, then open your terminal and right-click on the cursor and "paste filenames"

tasdvl9
Posts: 92
Joined: Fri Dec 06, 2013 3:55 am

Re: Livecode x64 7.0.6 installer not running..

Post by tasdvl9 » Tue Jul 28, 2015 4:15 pm

Hi,

I tried that as well but to no avail.
./LiveCodeInstaller-7_0_6-Linux.x64

This may be an issue with Fedora 14 x86_64.

Thanks.

wsamples
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 190
Joined: Mon May 18, 2009 4:12 am

Re: Livecode x64 7.0.6 installer not running..

Post by wsamples » Tue Jul 28, 2015 5:08 pm

Did attempting to open it from the commandline return any message? Did you try ldd? Have other versions of LiveCode installed and run on this system? If so, were they 32bit or 64bit? Did you check the release notes and install all the required and "optional" (in recent versions of LC some of these may not be optional!) dependencies?

It could be that you have outdated lib versions, but sometimes we find that running from the commandline will return messages telling us about that. Some newer distro releases (Mint and openSUSE Tumbleweed) may have lib incompatibilities going the other direction, but that would seem unlikely in your case.

tasdvl9
Posts: 92
Joined: Fri Dec 06, 2013 3:55 am

Re: Livecode x64 7.0.6 installer not running..

Post by tasdvl9 » Tue Jul 28, 2015 5:28 pm

Hi,

Thanks for the response. I was able to successfully install 6.5.2 on my x86_64 bit system a while back.
7.0 and above exhibits the same issue on my system.

Since I'm using 7.0.6 on my Windows system I was hoping to install it on my Fedora x86_64 system as well.

Unfortunately when I run it from the command line nothing returns back.
I did try running ldd the other day but nothing looked out of the ordinary.
Here is the output:

ldd ./LiveCodeInstaller-7_0_6-Linux.x64
linux-vdso.so.1 => (0x00007ffffbd47000)
libdl.so.2 => /lib64/libdl.so.2 (0x00000031a2000000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00000031a1c00000)
libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00000031ac000000)
libm.so.6 => /lib64/libm.so.6 (0x00000031a2800000)
libc.so.6 => /lib64/libc.so.6 (0x00000031a1800000)
/lib64/ld-linux-x86-64.so.2 (0x00000031a1400000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00000031a3000000)

wsamples
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 190
Joined: Mon May 18, 2009 4:12 am

Re: Livecode x64 7.0.6 installer not running..

Post by wsamples » Tue Jul 28, 2015 6:32 pm

Have you tried installing a 32bit version of LC 7.0.x ? I was running openSUSE Tumbleweed (rolling release) and system updates made around Dec or Jan wreaked havoc with version 7 of LiveCode. Neither 32bit nor 64bit ran correctly. The problem(s) may have been related but behavior was not identical. (openSUSE 13.1 and 13.2 have no problems.) You may have better luck than I did and be able to run the 32bit version. You may find you problems with the license and prefs files switching between versions, btw. Mark Wieder has reported problems similar to mine under Mint 17(IIRC) and filed a bug report which support could not duplicate.

tasdvl9
Posts: 92
Joined: Fri Dec 06, 2013 3:55 am

Re: Livecode x64 7.0.6 installer not running..

Post by tasdvl9 » Tue Jul 28, 2015 7:34 pm

Hi, thanks for all your help.

I tried both x64 and x86 versions of 7.0.6 and wasn't able to get both of those installers to execute.

The last installer which worked properly for me was 6.5.2

mwieder
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2673
Joined: Mon Jan 22, 2007 7:36 am
Location: Berkeley, CA, US
Contact:

Re: Livecode x64 7.0.6 installer not running..

Post by mwieder » Wed Jul 29, 2015 7:01 am

Something in the back of my head is nagging me about Fedora 14.
It's been a while (14 is a bit long in the tooth these days), so I can't put my finger on it.
Do you have gksu in your system? What about the ia32lib hierarchy for 32-bit binaries?
What happened when you launched from the command line?
Are there any livecode entries when you list the processes with "ps ax | grep livecode" ?

I just tried a new install of 7.0.6 commercial on my linux Mint 17, and after setting the executable bit it launched with no problems.
I realize that's no consolation, but it does rather point to the problem not being with the binary build itself.
There *was* an earlier build of 7.x that had library problems on debian wheezy, but those got resolved.

MaxV
Posts: 1489
Joined: Tue May 28, 2013 2:20 pm
Location: Italy
Contact:

Re: Livecode x64 7.0.6 installer not running..

Post by MaxV » Fri Jul 31, 2015 4:08 pm

First of all try to install this package: http://www.maxvessi.net/livecode/linux/

It will install all missing dependencies

Then reboot and install your commercial livecode.
Livecode Wiki: http://livecode.wikia.com
My blog: http://livecodeitalia.blogspot.it
To post code use this: http://tinyurl.com/ogp6d5w

mwieder
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2673
Joined: Mon Jan 22, 2007 7:36 am
Location: Berkeley, CA, US
Contact:

Re: Livecode x64 7.0.6 installer not running..

Post by mwieder » Fri Jul 31, 2015 6:17 pm

Also, have you tried installing as root?

tasdvl9
Posts: 92
Joined: Fri Dec 06, 2013 3:55 am

Re: Livecode x64 7.0.6 installer not running..

Post by tasdvl9 » Fri Aug 14, 2015 7:48 pm

Just curious but has anyone else tried running the 7.0.6 installer on Fedora 14 x86_64?

All versions before 7.0 seem to install properly.

The issue I am having is the installer doesn't seem to execute even from the command line.

mwieder
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2673
Joined: Mon Jan 22, 2007 7:36 am
Location: Berkeley, CA, US
Contact:

Re: Livecode x64 7.0.6 installer not running..

Post by mwieder » Sat Aug 15, 2015 3:21 am

Been a while since I've used Fedora...

if you're installing for all users, is gksu in the system? I seem to recall that it wasn't present without explicitly installing it.
and (forgive the dumb question) did you set the executable bit on the installer?

MaxV
Posts: 1489
Joined: Tue May 28, 2013 2:20 pm
Location: Italy
Contact:

Re: Livecode x64 7.0.6 installer not running..

Post by MaxV » Wed Aug 19, 2015 9:26 am

Hi all,
starting form version 7 livecode for linux has been split livecode in 32bit version and 64bit version. So I suppose that library requirements are now very different.
I made the DEB and RPM packages for livecode 6 (containing all dependencies), but they seems not to be enough for version 7.
Do you now what libraries are required for version 7?
Livecode Wiki: http://livecode.wikia.com
My blog: http://livecodeitalia.blogspot.it
To post code use this: http://tinyurl.com/ogp6d5w

Post Reply

Return to “Linux”