LiveCode doesn't work on Linux (Debian Jessie)

Deploying to Linux? Get penguinated here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

bogs
Posts: 720
Joined: Sat Feb 25, 2017 10:45 pm

Re: LiveCode doesn't work on Linux (Debian Jessie)

Post by bogs » Sat Sep 23, 2017 2:52 pm

Well, among others, I've run on pure Debian Jessie, and a great deal more. I haven't had an issue installing stable versions of Lc back to 6.0.1 on any of them, whether they were deb or rpm based, but I do know others do, like our friend recently who had issues on Fedora 25.

I'll have to do an install of Jessie fresh tonight and try to recreate this issue.
ImageImage

bogs
Posts: 720
Joined: Sat Feb 25, 2017 10:45 pm

Re: LiveCode doesn't work on Linux (Debian Jessie)

Post by bogs » Sun Sep 24, 2017 4:00 am

Ok, so I had a new thumbdrive that I had been planning to install debian on anyway :twisted: so I used that as my test guinea pig. My rigs an amd64, here is how it went.

1. Installed debian lxde 64 - wheezy (what I had for an iso handy)

2. ran apt-get update / upgrade / dist-upgrade (always my first step after a fresh install)

3. followed the debian instruction here to upgrade to *Jessie

4. now that jessie was in place, ran apt-get update / upgrade / dist-upgrade again
- realized I mixed up berserk's and andrewferguson's posts, andrew was actually running lxde, berserk is running mate (doh)! :oops:
- installed debian Mate desktop, purged lxde desktop and dependencies (doh!) :oops:

5. downloaded Lc 8.1.6 64 (latest stable version as of this posting)

6. immediately hit that backdrop bug (p u)
- alt-tabbed to Lc, view menu, unchecked backdrop

7. ran the interactive tutorial
- I found the list on the left to be interesting, however the tutorial found it less amusing when I used it to set the mouseUp event. :lol:
Image

8. having finished the tutorial with no other issues, I chose file/new stack/default size
- added a label, field, and 2 buttons
- set names for a little fancier 'hello' program
- no issues seen
Image

*in addition to the default repositories, I enabled contrib and non-free in the sources list
__________________________________________________________________

In this case, I installed only for myself, however I don't know that it would have made any difference going for all users.

For the issues described by berserk, I can only think of a few problems aside from what Max pointed out, but would need testing from the command line to determine it for sure. Sometimes programs that are partially running as he describes the problem can be determined starting it from the cli, by seeing what it reports failing.

Otherwise, try Max's launcher, as that will almost certainly pick off things you might be missing. As far as a pure fresh Debian installation, though, I see no issue.
ImageImage

bogs
Posts: 720
Joined: Sat Feb 25, 2017 10:45 pm

Re: LiveCode doesn't work on Linux (Debian Jessie)

Post by bogs » Sun Sep 24, 2017 4:24 pm

Experimenting with other distros, I did find that LMDE2 (Linux Mint Debian Edition2, which uses the Mate environment from wheezy) does have some issues with displaying Lc properly, at least with earlier versions, like 6.0.1. It seems there are pixbuf errors in the mint themes, and those versions have problems finding engines in various other themes.

The biggest error 8.1.6 displayed, however, was hardly an event ender. As shown below, there was a call to a deprecated function, and an incorrect rgb profile. Neither would have prevented text from being used.
Image

I took the time to also download the latest debian jessie/Mate installer, will see if I can reproduce the issue with that since it is possible the other way I installed it may have installed libraries not used by a straight up Mate install.
ImageImage

bogs
Posts: 720
Joined: Sat Feb 25, 2017 10:45 pm

Re: LiveCode doesn't work on Linux (Debian Jessie)

Post by bogs » Sun Sep 24, 2017 10:19 pm

Hmm. I could have sworn I submitted a post about the latest live Debian/Jessie/Mate attempt I did earlier today, but I don't see it anymore :(

Anyway, to make my longer post short and sweet, I downloaded and ran the live cd 64 bit version of the above, and instead of installing it, proceeded to download and install Lc 8.1.6 directly from the live environment.

The install went smoothly with no issues either following the interactive tutorial, or creating a hello world program with several widgets attached for ha ha's, so I am unsure why our friend berserk had such issues.

Nothing aside from the errors above showed up when running it from the command line, and no updates or upgrades were performed before running it.
ImageImage

Detlef
Posts: 2
Joined: Wed Oct 18, 2017 5:27 pm

Re: LiveCode doesn't work on Linux (Debian Jessie)

Post by Detlef » Wed Oct 18, 2017 5:44 pm

Hello,
this article was very helpfull and the post from MaxV inspire me to create two files.
myuser must exchange with the correct user !

StartLiveCode.sh

#!/bin/bash
cd /home/myuser/.runrev/components/livecodecommunity-8.1.6.x86_64
export LC_ALL= LC_NUMERIC=C
export LIBGL_DRI3_DISABLE=1
./livecodecommunity.x86_64

Starting this in an Terminal will execute LiveCode having all features available in UBUNTU and KUBUNTU
I run Ubuntu 16.04 and Kubuntu 17.10 in an VBox Environment !


To have the possibility to open by double click i create the desktop file.

RunLiveCode.desktop

[Desktop Entry]
Name=LiveCode
Comment=Start LiveCode
Exec=/home/myuser/.runrev/components/livecodecommunity-8.1.6.x86_64/StartLiveCode.sh
Icon=/home/myuser/.runrev/components/livecodecommunity-8.1.6.x86_64/Runtime/Android/notify_icon.png
Terminal=false
Type=Application


this enable me double click open LiveCode as expected

And if you fast enough you can add it to the launch bar as icon ;-)
(Try it and you see what i mean )
oOn Kubuntu i was not able to implement in my Favorites,
(Never the less i guess thats my fault and i spend not to much time here)
however i put an link on my Ubuntu Desktop and it work.

have a nice day
Detlef

bogs
Posts: 720
Joined: Sat Feb 25, 2017 10:45 pm

Re: LiveCode doesn't work on Linux (Debian Jessie)

Post by bogs » Wed Oct 18, 2017 7:48 pm

Cool stuff Detlef.
ImageImage

Post Reply

Return to “Linux”