Old standalones work, IDE versions don't

Deploying to Mac OS? Ask Mac OS specific questions here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

jmk_phd
Posts: 89
Joined: Sat Apr 15, 2017 8:29 pm

Re: Old standalones work, IDE versions don't

Post by jmk_phd » Thu Jul 19, 2018 12:32 am

Jacque --

Thanks so much!

The two lines of code that you recommended be added immediately after the answer command did indeed resolve the problem. Upon clicking the "OK" button in the answer dialog, the test items again responded to keyboard presses without first needing to click on the frontmost window.

I'm still not sure why my original app worked a year or so ago, yet broke now until inserting your two new lines of code. Although I'd like to know, most important is that the app is working again.

Just in case it makes any sense to anyone, one possibility is that because my app required that the entire screen background be set to black, I had to tinker with the background color of the built-in LC "Answer Dialog" stack in order for the dialog window to display with a white background. Perhaps that built-in stack remained the default even after being dismissed.

In any case, I seem to be back on track to complete this app, so I truly appreciate everyone's help.

jeff k

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 5466
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Old standalones work, IDE versions don't

Post by jacque » Thu Jul 19, 2018 3:12 am

Changing the backcolor of the answer dialog is a pretty common thing to do and is only cosmetic, so it's doubtful that would interfere, especially if it's done before the dialog displays.

There have been a lot of changes in the last two years, so it's possible you did find a minor bug. It wouldn't hurt to report it and see what the team thinks. Meanwhile I'm glad you have a workaround.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

ChristianBC
Posts: 9
Joined: Wed Jul 15, 2020 12:38 am

Re: Old standalones work, IDE versions don't

Post by ChristianBC » Thu Jul 30, 2020 7:02 am

Hello!

did you finish your project? Did you find the cause of the problem? a missing pop card command, a lock message, a group behaving as a background? a dynamic path working differently? a frontscript?

Can you a minimal stack with the same problem?

Thank you!

jmk_phd
Posts: 89
Joined: Sat Apr 15, 2017 8:29 pm

Re: Old standalones work, IDE versions don't

Post by jmk_phd » Fri Aug 07, 2020 3:47 pm

Hi ChristianBC --

In answer to your first question: My project is finished, but not yet published (because I've yet to figure out how to master Apple's ever-more draconian method of signing and authenticating applications).

As regards the cause of the IDE-vs-standalone problem I experienced, the fix suggested by Jacque back on 16 July 2018 worked for me. I've just run the app in the LC 9.5.x IDE and found that everything still works okay.

In case your question was prompted by a problem you've had with trying to run an older stack in a newer LC IDE, I'd just refer back to Jacque's point that the LC IDE has undergone lots of changes over the past few years. Any glitch in your older stack may differ from the one that she spotted in my code, so you might want to post the specifics to a new question in this forum.

jeff k

Post Reply

Return to “Mac OS”