Font load fails only when app in Mac Apps folder

Deploying to Mac OS? Ask Mac OS specific questions here.

Moderators: heatherlaine, Klaus, FourthWorld, robinmiller, kevinmiller

Post Reply
tomBTG
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 49
Joined: Fri Nov 25, 2011 6:42 pm
Location: Kansas City
Contact:

Font load fails only when app in Mac Apps folder

Post by tomBTG » Wed Feb 28, 2018 2:55 pm

Hi Livecoders.

I have an odd Mac standalone issue. I use FontAwesome for some icons, and those icons fail to appear only when the standalone is run from inside the Mac Applications folder.

The app is codesigned as a third-party developer ID using AppWrapper and verified. It is not for App Store distribution. Mac Sierra, Livecode Indy 7.1.4.

Anybody know why the font load is blocked?

Thanks,
Tom B.

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 4462
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Font load fails only when app in Mac Apps folder

Post by jacque » Wed Feb 28, 2018 7:09 pm

Is the font included in the Copy Files pane of standalone settings?
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

tomBTG
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 49
Joined: Fri Nov 25, 2011 6:42 pm
Location: Kansas City
Contact:

Re: Font load fails only when app in Mac Apps folder

Post by tomBTG » Wed Feb 28, 2018 10:29 pm

Is the font included in the Copy Files pane of standalone settings?
Yes, it is.

I have confirmed the font loads and works because when the app is not in the Applications folder, the icons that use the font appear as expected. The only time the font fails to load and display is when the same app is dropped into the Applications folder. (I'm using a MacBook Pro running Sierra. The App standalone was compiled on this same Mac using LC Indy 7.1.4)

Seems like a sandboxing / permissions problem. Everything else about the app runs normally.

Thanks,
Tom

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 4462
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Font load fails only when app in Mac Apps folder

Post by jacque » Thu Mar 01, 2018 12:08 am

That was my thought too, it's the permissions. I wonder if you have to code-sign the font file too.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

Post Reply

Return to “Mac OS”