Problem with "get" command

Deploying to Mac OS? Ask Mac OS specific questions here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
Posts: 79
Joined: Fri Oct 14, 2011 6:53 am

Problem with "get" command

Post by » Thu Nov 09, 2017 12:21 pm

I have several "post" commands in my application and these work as they should.

The problem is that I need a "get" command at one place and then I get the following errors:

<! DOCTYPE HTML PUBLIC "- // W3C // DTD HTML 4.01 // EN" "">
<HTML> <HEAD> <TITLE> Not Found </ TITLE>
<META HTTP-EQUIV = "Content-Type" Content = "text / html; charset = us-ascii"> </ HEAD>
<BODY> <h2> Not Found </ h2>
<hr> <p> HTTP Error 404. The requested resource is not found. </ p>
</ BODY> </ HTML>

It appears that the "post" command, somehow blocks the "get" command.

This applies even if I open my application with all the "post" command and then an application with a "get" command in my Livecode IDE and try to test them in that order, I get the same error, despite the fact that there are two separate applications, In reverse order, it works as it should.

Same thing if I delete all the "post" command in my application, before the "get" command, then it works.

If I paste the generated string into my browser, it also works. I only get this error through my application/s regardless if I run them in my IDE or as a standalone and only when the Get command follow the "post" command.

How is it that, anyone?

/// Peter

VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 583
Joined: Wed Nov 22, 2006 3:42 pm
Location: France

Re: Problem with "get" command

Post by Thierry » Thu Nov 09, 2017 1:05 pm

Hi Peter,

shooting a bit in the dark...

could you try to add this line before your get url?

set the httpHeaders to empty


Thierry Douez -
Pourquoi tant de notes lorsqu'il suffit de jouer les plus belles... [Barbara]
Posts: 79
Joined: Fri Oct 14, 2011 6:53 am

Re: Problem with "get" command

Post by » Thu Nov 09, 2017 3:06 pm


Work like a charm

Many thanks


Post Reply

Return to “Mac OS”