Cannot add iOS SDK

Deploying to Mac OS? Ask Mac OS specific questions here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
fredotech
Posts: 2
Joined: Fri Dec 30, 2016 8:45 pm

Cannot add iOS SDK

Post by fredotech » Fri Dec 30, 2016 8:52 pm

I'm running: MAC Sierra and LiveCode8.1.2 Build14013 Xcode 8.2.1

I have installed the following iso SDK on the machine:
10.1, 10.0, 9.2 & 8.2.

I get the error that says : the chosen folder is not a valid iso SDK.

See attachment
2016-12-30_12-33-34.jpg
Error
Need help

PBH
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 80
Joined: Sun Feb 20, 2011 4:26 pm
Location: Vancouver Island, BC, Canada. ex.UK
Contact:

Re: Cannot add iOS SDK

Post by PBH » Sat Dec 31, 2016 6:35 am

The correct version of Xcode for LC8.1.2 is Xcode 8.1. It is usually listed in the release notes.

If I remember correctly LC8.1.2 was released a day or two before Apple updated Xcode, this constant upgrade cycle has caused me (and others) a few headaches in the past, so now I always back up Xcode to a separate drive as soon as I find a working combination.

If you have your App Store prefs set to install app updates then you will run into this problem more often.

Paul

fredotech
Posts: 2
Joined: Fri Dec 30, 2016 8:45 pm

Re: Cannot add iOS SDK

Post by fredotech » Sat Dec 31, 2016 6:59 pm

that was the issue. Thank you. I downloaded 8.1 and installed and linked.

mroam
Posts: 11
Joined: Tue Nov 27, 2007 8:11 pm
Location: Brooklyn, NY USA
Contact:

Re: Cannot add iOS SDK

Post by mroam » Sat Jul 08, 2017 5:07 am

I've found that the page at https://livecode.com/support/ask-a-ques ... -livecode/ is helpful for this kind of thing: it lists versions of LiveCode from ancient 5.5 to this month's 9.0.0dp7 and shows what version of macOs and Xcode they work with.

The following lines from that page look helpful for my effort to compile an iOS app on mac:
LiveCode 8.1.4 STABLE – Xcode 7.2 -Mac OS 10.10 – iOS 9.2
LiveCode 8.1.4 STABLE – Xcode 8.2 -Mac OS 10.11 – iOS 10.2
LiveCode 8.1.4 STABLE – Xcode 8.3 -Mac OS 10.12 – iOS 10.3
...
LiveCode 9.0 DP-7 – Xcode 7.2 -Mac OS 10.10 – iOS 9.2
LiveCode 9.0 DP-7 – Xcode 8.2 -Mac OS 10.11 – iOS 10.2
LiveCode 9.0 DP-7 – Xcode 8.3 -Mac OS 10.12 – iOS 10.3

Post Reply

Return to “Mac OS”