8.1.6 Indy IDE VERY SLOW

Deploying to Windows? Utilizing VB Script execution? This is the place to ask Windows-specific questions.

Moderators: heatherlaine, Klaus, FourthWorld, robinmiller, kevinmiller

Post Reply
dsmithpm
Posts: 4
Joined: Fri Dec 29, 2017 7:35 pm

8.1.6 Indy IDE VERY SLOW

Post by dsmithpm » Fri Dec 29, 2017 8:17 pm

Greetings,
First time posting, but have been scripting professionally since Hypercard, Metacard, Supercard, Runrev, Livecode. For the first time I cannot figure this one out on my own.
Updated from 7.x to 8.1.6 recently as I wanted the browser widget and built in Telnet library for sFTP communication (Although it works well, was disappointed that communication is blocking in my paid version.)
I am 2 years into a project that assists water and wastewater operators with regulatory reporting, scheduling and asset management. The problem:

The 8.1.6 IDE grows increasingly slower over time. About 20 minutes of coding and interface work and the IDE becomes so slow it is painful. The code editor starts missing keystrokes, After return on a line it takes seconds for the cursor to reappear. Simple click selection of controls takes seconds to become focused. Nudging a few controls takes so long you think its locked up. Menu selecting "Edit Script" takes 5 to 10 seconds. Yes the processor load ramps above 50% to the point every fan is full speed. A peek at the task manager shows no other processes being hoggish.
A co-programmer working on the same project in another office experiences identical extreme slow down over a short time on his gaming laptop.

Hardware: Intel i5-4210U at 2.40 GHz. 8 GB RAM, 64 bit
System: Windows 10 Pro 64 bit
Project: 6 stacks consisting of ~6000 lines of code. Every stack <2000 lines of code across several objects.

Project runs very fast and efficient after compile
Hoping there is something other than reverting to 7 to fix this.

Doug Smith
Envirence Software
Doug Smith
Envirence Software

Klaus
Posts: 10168
Joined: Sat Apr 08, 2006 8:41 am
Location: Germany
Contact:

Re: 8.1.6 Indy IDE VERY SLOW

Post by Klaus » Fri Dec 29, 2017 8:33 pm

Hi Doug,

welcome to the forum! :D

Could you please try version 8.1.8? They fixed a lot of things there.
Get this and any other version of LC here: http://downloads.livecode.com/livecode/


Best

Klaus

dsmithpm
Posts: 4
Joined: Fri Dec 29, 2017 7:35 pm

Re: 8.1.6 Indy IDE VERY SLOW

Post by dsmithpm » Sat Dec 30, 2017 12:42 am

Thank You Klaus!
I hadn't checked back in a while to see the latest stable versions.
Version 8.1.8 is much better in my tests so far. Only anomaly... Typing in the message box is delayed, but I can deal with that.
So now that I have finally registered here, perhaps I can pay it forward and offer help to others if I can.

Happy New Year!
Doug
Doug Smith
Envirence Software

bogs
Posts: 1913
Joined: Sat Feb 25, 2017 10:45 pm

Re: 8.1.6 Indy IDE VERY SLOW

Post by bogs » Sat Dec 30, 2017 2:13 am

dsmithpm wrote:
Sat Dec 30, 2017 12:42 am
So now that I have finally registered here, perhaps I can pay it forward and offer help to others if I can.
The more the merrier I always say, welcome aboard :D
Image

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 6040
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: 8.1.6 Indy IDE VERY SLOW

Post by FourthWorld » Sat Dec 30, 2017 3:49 am

dsmithpm wrote:
Sat Dec 30, 2017 12:42 am
Only anomaly... Typing in the message box is delayed, but I can deal with that.
Is that consistent? Do you have a recipe? Ideally the MB should be pretty snappy. So if it's not, we should make it so.
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

dsmithpm
Posts: 4
Joined: Fri Dec 29, 2017 7:35 pm

Re: 8.1.6 Indy IDE VERY SLOW

Post by dsmithpm » Sat Dec 30, 2017 4:08 am

Working through this evening the delay in MB response is intermittent. Recipe: Seems to be directly after debugger reporting an error in Script debug Mode. I've noticed the debugger is slow in producing the pointer to the error and slow in allowing editing after hitting continue.
Turned off script debug mode and slow MB response has not occurred since? Coincidence?

Initially it was only happening when the Doobie Brothers were playing on ITunes.
Doug Smith
Envirence Software

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 6040
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: 8.1.6 Indy IDE VERY SLOW

Post by FourthWorld » Sat Dec 30, 2017 5:10 am

dsmithpm wrote:
Sat Dec 30, 2017 4:08 am
Working through this evening the delay in MB response is intermittent. Recipe: Seems to be directly after debugger reporting an error in Script debug Mode. I've noticed the debugger is slow in producing the pointer to the error and slow in allowing editing after hitting continue.
Turned off script debug mode and slow MB response has not occurred since? Coincidence?
That seems like a good narrowing-down. Windows-specific optimizations are in progress, but I'm working in Windows more right now on one of my projects and will keep an eye out for things like this. I'll post anything new I see here.
Initially it was only happening when the Doobie Brothers were playing on ITunes.
Try King Crimson and see if that alters the timing. ;)
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 4502
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: 8.1.6 Indy IDE VERY SLOW

Post by jacque » Sat Dec 30, 2017 6:02 pm

I've seen something similar on a Mac, it happens only after debugging. In my case it only affected a drag operation which began to stutter noticeably and sometimes didn't respond at all.

The problem seems to be a backup of pending messages from the IDE. The fix is to open the messages pane in the message box, which seems to clear the backup. You don't have to do anything else, just go to the pane.

If that fixes your problem then a bug report would be in order.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

dsmithpm
Posts: 4
Joined: Fri Dec 29, 2017 7:35 pm

Re: 8.1.6 Indy IDE VERY SLOW

Post by dsmithpm » Sun Dec 31, 2017 4:50 am

Thank you Jacque,
Interesting. I repeatedly, purposefully injected an error in the code, not that I don't unintentionally often enough, with script debug mode on. And performed various tasks such as nudging objects, typing in the message box, moving controls etc. after continuing from the debugger trap, and noticed marked sluggishness in each succeeding task. The slow down seems to last 10 to 15 seconds and then clears.
In subsequent tests I immediately clicked on pending messages in the message box as you suggested and pending messages apparently flushed right away. The sluggishness thereafter gone until another error was trapped.
At least I know how to restore normal response time now.
Is this something I should send as a bug report?
Thanks Again
Doug Smith
Envirence Software

bogs
Posts: 1913
Joined: Sat Feb 25, 2017 10:45 pm

Re: 8.1.6 Indy IDE VERY SLOW

Post by bogs » Sun Dec 31, 2017 5:04 am

jacque wrote:
Sat Dec 30, 2017 6:02 pm
If that fixes your problem then a bug report would be in order.
I'd say it sounds buggish, since 3 different systems are doing the same thing apparently.
dsmithpm wrote:
Fri Dec 29, 2017 8:17 pm
A co-programmer working on the same project in another office experiences identical extreme slow down over a short time on his gaming laptop.
Curious, other than being a laptop, are the other particulars the same/similar, i.e. win10, intel chipset, etc?
Image

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 4502
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: 8.1.6 Indy IDE VERY SLOW

Post by jacque » Sun Dec 31, 2017 5:23 am

dsmithpm wrote:
Sun Dec 31, 2017 4:50 am
Is this something I should send as a bug report?
Yes, please do. Now that we know it's repeatable they can fix it. It looks to me like the message that saves your breakpoints and other debug info to the prefs file is firing too often.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

werner
Posts: 8
Joined: Wed Jun 22, 2016 11:37 am

Re: 8.1.6 Indy IDE VERY SLOW

Post by werner » Wed Jul 11, 2018 12:53 pm

Good day, I know this is an old post but I am experiencing the exact same issue on LC 9 for Business on Windows. The IDE becomes very slow and resizing large scripts are very unresponsive. Is there something in LC that can be set to improve performance? On MAC I don't have the same issue with the IDE except that debugging and to step through code is slow.

Klaus
Posts: 10168
Joined: Sat Apr 08, 2006 8:41 am
Location: Germany
Contact:

Re: 8.1.6 Indy IDE VERY SLOW

Post by Klaus » Wed Jul 11, 2018 1:10 pm

Hi Werner,

LC released version 9.01 RC 1 yesterday and they write:
...
the performance of the IDE on Windows is significantly improved
...
Get it here, at least worth a try:
https://downloads.livecode.com/livecode/

Best

Klaus

werner
Posts: 8
Joined: Wed Jun 22, 2016 11:37 am

Re: 8.1.6 Indy IDE VERY SLOW

Post by werner » Fri Jul 20, 2018 2:00 pm

Hi Klaus

Thank you, I will try it.

Kind Regards
Werner

Post Reply

Return to “Windows”