failed to load external

Are you developing an External using the LiveCode Externals SDK?

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller, kevinmiller

Post Reply
Tiemo
Posts: 30
Joined: Wed Feb 21, 2007 3:37 pm
Location: Kassel, Germany
Contact:

failed to load external

Post by Tiemo » Wed Mar 30, 2016 2:35 pm

Hello,
Developing on Win 64 Bit I am using two externals, which works fine up to LC 6.7. But in LC 7 and 8 I get "Initialisation error - failed to load external", when launching the runtime.

The externals and the externals.txt are located at: ": C:\Users\<myUser>\Documents\My LiveCode\Runtime\Windows\x86-32\Externals"
and in: "C:\Users\<myUser>\Documents\My LiveCode\Externals"
The files& memory\user extensions preference is: "C:\Users\<myUser>\Documents\My LiveCode"

This setting works fine with LC 6.7 in IDE and runtime, but in LC 7 and 8 it works only in the IDE and trows the above runtime error.
There must have been changed something obvious with LC 7/8, what I don't see.
Any idea, what to check for?
Thanks
Tiemo

Tiemo
Posts: 30
Joined: Wed Feb 21, 2007 3:37 pm
Location: Kassel, Germany
Contact:

Re: failed to load external

Post by Tiemo » Thu Mar 31, 2016 12:15 pm

SOLVED
I am not quit sure, because I tried different things, but think it was an incompatible version of revxml.dll or revzip.dll.
After I copied the newest versions of those dlls from the LC 8 installation dir into my test environment, the failure was gone.

Post Reply

Return to “Building Externals/Plugins”