Help with legacy on-rev site on new LiveCode host

Are you using LiveCode to create server scripts or CGIs?

Moderators: heatherlaine, Klaus, FourthWorld, robinmiller, kevinmiller

Post Reply
Martin Koob
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 223
Joined: Sun May 27, 2007 8:19 pm

Help with legacy on-rev site on new LiveCode host

Post by Martin Koob » Wed Mar 30, 2016 1:56 am

Hi,

I have an site on on-rev TIO that was working but now that it has been transferred to the new site it generates livecode errors on some pages.

I had this problem a couple of years ago but David Williams had managed to make it run on TIO which would accept the legacy site using LiveCode server 4.6.4

Now with the new site I am sure that is not an option.

I have found one issue that I fixed, a variable was named SESSION which is a reserved word in LiveCode as of 5.0 I also found there is a variable REQUEST which is an array. I think I ran into this before and renamed them $_POST. Is that correct?

Is there any document on on changes between LiveCode server 4.6.4 and later versions and how to transition? I looked at http://downloads.livecode.com but after version 5.0 I don't see specific documentation for server.

Thanks

Martin

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 5812
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: Help with legacy on-rev site on new LiveCode host

Post by FourthWorld » Wed Mar 30, 2016 1:58 am

Any script errors are output by the engine to the Apache error log. Does on-rev provide access to your error log?
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

Martin Koob
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 223
Joined: Sun May 27, 2007 8:19 pm

Re: Help with legacy on-rev site on new LiveCode host

Post by Martin Koob » Wed Mar 30, 2016 2:33 am

Hi Richard

Thanks for your response.

Where would the apache error log be located?

I found that if I comment out the following lines the page will load. Any Idea of what the LiveCode server does not like here?

/*
# general details
put gSESSION["userId"] into tVars[1]
put $_POST["acFName"] into tVars[2]
put $_POST["acLName"] into tVars[3]
put $_POST["acEmail"] into tVars[4]

if $_POST["acNews"] = "Y" then
put "Y" into tVars[5]
else
put "N" into tVars[5]
end if

put $_POST["acPass1"] into tVars[6]

*/

Martin

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 5812
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: Help with legacy on-rev site on new LiveCode host

Post by FourthWorld » Wed Mar 30, 2016 4:37 am

Martin Koob wrote:Where would the apache error log be located?
Looks like you found 'em, yes?:
http://lists.runrev.com/pipermail/use-l ... 25177.html
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

Martin Koob
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 223
Joined: Sun May 27, 2007 8:19 pm

Re: Help with legacy on-rev site on new LiveCode host

Post by Martin Koob » Wed Mar 30, 2016 5:58 am

Thanks Richard.

I got it fixed. I posted what I had to do in the use list.

http://runtime-revolution.278305.n4.nab ... 02774.html

Martin

Post Reply

Return to “CGIs and the Server”