mySQL not working in standalone

Creating desktop or client-server database solutions?

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller, kevinmiller

Post Reply
adventuresofgreg
Posts: 314
Joined: Tue Oct 28, 2008 1:23 am
Contact:

mySQL not working in standalone

Post by adventuresofgreg » Sun Feb 28, 2016 3:37 pm

Hello: I'm compiling a standalone using LC 5.5.1 and I can't connect to my mySQL database (remote). I selected "Select inclusions for the standalone application", checked "Database Support" and included "MySQL". When I connect using the following script, nothing happens. It seems like the database support inclusions aren't being saved into the standalone. ???

global gconnectionID
on mouseUp

put field "SQLdomain" on stack "settings" into tDatabaseAddress
put field "SQLdbaseName" on stack "settings" into tDatabaseName
put field "SQLuser" on stack "settings" into tDatabaseUser
put field "SQLpass" on stack "settings" into tDatabasePassword

-- connect to the database
-- Keep trying if you cant connect

repeat until tResult is a number
put revOpenDatabase("MySQL", tDatabaseAddress, tDatabaseName, tDatabaseUser, tDatabasePassword) into tResult
put tResult into gConnectionID
put "trying to connect to SQL..." && tResult into field "thestatus"
end repeat

put "connected to SQL..." && tResult into field "thestatus"
end mouseUp

adventuresofgreg
Posts: 314
Joined: Tue Oct 28, 2008 1:23 am
Contact:

Re: mySQL not working in standalone

Post by adventuresofgreg » Sun Feb 28, 2016 5:55 pm

Never mind. I am stupid. (I forgot to copy the windows externals folder over with the .exe). It works like a charm.

Post Reply

Return to “Databases”