Android browser is slow

Bringing the internet highway into your project? Building FTP, HTTP, email, chat or other client solutions?

Moderators: heatherlaine, Klaus, FourthWorld, robinmiller, kevinmiller

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 4669
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Android browser is slow

Post by jacque » Tue Jan 30, 2018 9:49 pm

Using the URL you sent in private mail, I can reproduce the problem. Loading is quick enough and I don't see any lag when scrolling (I have a pretty fast phone,) but as you reported, sometimes the page scrolls in the opposite direction it is supposed to. It can also snap to the top or bottom unexpectedly. I wish I'd asked for a URL earlier, we could have saved some time. :)

This looks like a bug in the widget to me, possibly related to the fact that the page is written in a right-to-left language. You should report it at http://quality.livecode.com. Be sure to give them the URL, since the behavior doesn't happen on left-to-right language pages. If you don't want to publicly post the URL, you can send it to Panos privately -- he will give you an email address if you ask in your bug report.

If you haven't ever sent in a bug report, you will need to create a free account. You can't use your forum login there. Sorry we can't fix it in script, but I'm glad we found the reason.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 4669
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Android browser is slow

Post by jacque » Tue Jan 30, 2018 9:56 pm

My first test was with LC 9 dp 11. I just tested in LC 8.1.8. Scrolling in LC 8 is somewhat jerkier though not terrible, which may be the lag you reported. It does still scroll backwards periodically but not as often. Basically LC 8 appears to take a little more time to respond to a swipe gesture, which could be why it doesn't fail quite as much.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

LiadTal6
Posts: 36
Joined: Sat Jul 25, 2015 5:26 pm

Re: Android browser is slow

Post by LiadTal6 » Tue Jan 30, 2018 10:09 pm

Thank you very much for checking it.
jacque wrote:
Tue Jan 30, 2018 9:49 pm
Using the URL you sent in private mail, I can reproduce the problem. Loading is quick enough and I don't see any lag when scrolling (I have a pretty fast phone,) but as you reported, sometimes the page scrolls in the opposite direction it is supposed to. It can also snap to the top or bottom unexpectedly. I wish I'd asked for a URL earlier, we could have saved some time. :)

This looks like a bug in the widget to me, possibly related to the fact that the page is written in a right-to-left language. You should report it at http://quality.livecode.com. Be sure to give them the URL, since the behavior doesn't happen on left-to-right language pages. If you don't want to publicly post the URL, you can send it to Panos privately -- he will give you an email address if you ask in your bug report.

If you haven't ever sent in a bug report, you will need to create a free account. You can't use your forum login there. Sorry we can't fix it in script, but I'm glad we found the reason.
What you described could be an option for the source of the problem, but if this is the problem why in the iphone browser it's working perfect and without any problem?
jacque wrote:
Tue Jan 30, 2018 9:56 pm
My first test was with LC 9 dp 11. I just tested in LC 8.1.8. Scrolling in LC 8 is somewhat jerkier though not terrible, which may be the lag you reported. It does still scroll backwards periodically but not as often. Basically LC 8 appears to take a little more time to respond to a swipe gesture, which could be why it doesn't fail quite as much.
So now you understand what I meant?
In every phone the speed and the lag is different, there is phones that is fine but there is phones that you can't use the app.
So now that you saw that it takes time to respond, do you have any idea how to solve it?

Thanks.

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 4669
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Android browser is slow

Post by jacque » Wed Jan 31, 2018 12:37 am

The only way to solve it is to tell LC and have them look. The problem isn't in the phone or your scripts; it is in the browser widget and the way it is implemented.

There is a difference between a dedicated browser app and a "web view" which is embedded inside another app. The embedding is done in the LC engine, so they need to fix it.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

LiadTal6
Posts: 36
Joined: Sat Jul 25, 2015 5:26 pm

Re: Android browser is slow

Post by LiadTal6 » Wed Jan 31, 2018 5:03 pm

But you said that in LC 9 dp 11 you didn't feel any lag, just that the page going up when scrolling down.
So if I will try to save my app in LC 9 you think it will be better?

Few days ago I downloaded LC 9 and tried to save another app for Android and when I opened the app in my phone it didn't work and I just saw a black screen, so that's another problem.

So in LC 9 the speed in Android with the URL that I gave you was fine?

Thanks.

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 4669
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Android browser is slow

Post by jacque » Wed Jan 31, 2018 5:31 pm

Speed was better in LC 9 but the scrolling direction was still wrong sometimes.

I think the black screen is because the minimum Android version is too low. Try setting it to Lollipop.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

LiadTal6
Posts: 36
Joined: Sat Jul 25, 2015 5:26 pm

Re: Android browser is slow

Post by LiadTal6 » Wed Jan 31, 2018 5:39 pm

I think that I can find some solutions for the page that going up when scrolling down, I'm gonna try to use another site to display my information.

But more important for me is the speed, so I will try to download LC 9 again and I will update about what will change.

Until then, thank you very much for your kind help.

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 4669
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Android browser is slow

Post by jacque » Wed Jan 31, 2018 8:12 pm

I just noticed another reason for the black screen:
http://quality.livecode.com/show_bug.cgi?id=20698

A work-around is in the bug report.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

LiadTal6
Posts: 36
Joined: Sat Jul 25, 2015 5:26 pm

Re: Android browser is slow

Post by LiadTal6 » Sat Feb 03, 2018 6:04 pm

I copied the code that is in the link, but nothing was changed.

I'm trying to do many things to solve the "black screen" issue and I don't have any success with it.
Any more solutions for the "black screen" issue please?

Thanks.

LiadTal6
Posts: 36
Joined: Sat Jul 25, 2015 5:26 pm

Re: Android browser is slow

Post by LiadTal6 » Sat Feb 03, 2018 6:28 pm

It doesn't matter which version I set it to, or if I delete the acceleratedRendering line in the proOpenStack, it still presenting just a black screen..

Any help?

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 4669
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Android browser is slow

Post by jacque » Sat Feb 03, 2018 10:04 pm

I think it's time to write to LC support.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

Post Reply

Return to “Internet”