can't use localhost in browser widget

Bringing the internet highway into your project? Building FTP, HTTP, email, chat or other client solutions?

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
raugert
Posts: 10
Joined: Thu May 26, 2016 9:30 pm

can't use localhost in browser widget

Post by raugert » Mon May 22, 2017 4:27 pm

I am running a local MAMP server on a macbook for html pages. These pages work OK on Chrome and Safari. I can't seem to read these pages from the browser widget in LC ?


What is the syntax to read from local server ?

Sorry, I tried to put an example of what I tried but I get this error when I include my syntax in this message >>> Your account does not have permission to post links or domain/page references.

The browser widget does work when I set the URL to Google -- so I know it works.

thanks for any help,

raugert
Posts: 10
Joined: Thu May 26, 2016 9:30 pm

Re: can't use localhost in browser widget

Post by raugert » Mon May 22, 2017 5:01 pm

I got it to work using 127.0.0.1 as IP instead of localhost or IP of computer !

Now I just need to get it to fit properly in the browser window... The html is made for television (1920x1080px) but I wan't to display it in a small browser window in my app. I'll create a new topic....

[-hh]
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 1553
Joined: Thu Feb 28, 2013 11:52 pm
Location: Göttingen, DE

Re: can't use localhost in browser widget

Post by [-hh] » Sun May 28, 2017 8:33 pm

Use localhost with the port number:

Code: Select all

set the URL of widget "browser" to "http://localhost:8888"
This is the default setting for MAMP (Mac). You can change the port number 8888 in MAMP's prefs to another one.

___
You can post URLs after reaching a certain number of posts.
shiftLock happens

Post Reply

Return to “Internet”