TSNet and SMTP : attachment file doesn't show up [SOLVED]

Bringing the internet highway into your project? Building FTP, HTTP, email, chat or other client solutions?

Moderators: heatherlaine, Klaus, FourthWorld, robinmiller, kevinmiller

Post Reply
bangkok
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 790
Joined: Fri Aug 15, 2008 7:15 am

TSNet and SMTP : attachment file doesn't show up [SOLVED]

Post by bangkok » Fri Dec 09, 2016 8:29 am

I use the stack "LCMail 1.1" (with LiveCode 8.1.1 Indy on Windows 8.1) provided by Charles Warwick, without any modification.

https://www.mail-archive.com/use-liveco ... 78527.html

I use a SMTP server "plain" on port 587.

It works perfectly well... However the attachment (a PDF file) is like "invisible" on the receiver side.

I've tried with Yahoo Mail (web client) and Thunderbird (desktop app)... same results : the e-mail is received, it has the correct size (the PDF file is converted in base64) but the attachment doesn't show up in the interface.

Could someone do a test on Windows and/or MacOS ?
Last edited by bangkok on Sat Dec 10, 2016 9:36 am, edited 1 time in total.

dave.kilroy
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 858
Joined: Wed Jun 24, 2009 1:17 pm
Location: Plymouth, UK
Contact:

Re: TSNet and SMTP : attachment file doesn't show up

Post by dave.kilroy » Fri Dec 09, 2016 1:43 pm

I used a tweaked version of Charles' code for an iOS app that sends an email with a pdf attachment (and which works fine) - can you check your pdf is ok before sending it?
"...this is not the code you are looking for..."

bangkok
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 790
Joined: Fri Aug 15, 2008 7:15 am

Re: TSNet and SMTP : attachment file doesn't show up [SOLVED

Post by bangkok » Sat Dec 10, 2016 9:35 am

I have a good news.

Charles (the creator of TSNet) was kind enough to do several tests with me.

Eventually, he found the cause of the problem. It was an issue with MIME format that affects some email client.

Updated stack :

https://downloads.techstrategies.com.au ... l.livecode

dave.kilroy
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 858
Joined: Wed Jun 24, 2009 1:17 pm
Location: Plymouth, UK
Contact:

Re: TSNet and SMTP : attachment file doesn't show up [SOLVED

Post by dave.kilroy » Sat Dec 10, 2016 3:14 pm

Excellent

I've been impressed with how well Charles has been supporting people moving over to tsNet
"...this is not the code you are looking for..."

Post Reply

Return to “Internet”