Page 1 of 1

Line numbers not scrolling in script editor

Posted: Wed Sep 19, 2018 5:57 am
by pderocco
This is 9.0.1 on Windows 7 x64. Sometimes I get into a state where scrolling the code pane in the script editor doesn't scroll the line numbers to its left. Clicking a number sets a breakpoint on that numbered line, not the line of code to its right.

I haven't figured out how to make this happen, but it's happened to me a bunch of times. Has anyone else seen this?

Re: Line numbers not scrolling in script editor

Posted: Wed Sep 19, 2018 8:13 am
by richmond62
A picture of what you mean would be very helpful.

Re: Line numbers not scrolling in script editor

Posted: Thu Sep 20, 2018 4:09 am
by pderocco
I don't see how. You would have no way of knowing that the line numbers were wrong.

It's simple. The script editor gets into a state where I can scroll the script with the mouse wheel or the scrollbar, but the numbers to the left just sit there. When it is in this state, it affects every script that is open in the editor, and affects newly opened scripts. The only way to fix it is to close the script editor and reopen it again, which means reloading the various scripts I'm working one. So somewhere in the scrolling code, I suspect an exception is getting thrown before it has a chance to make the numbers align with the script, and the exception is being swallowed.

What would be useful is knowing how to provoke this bug. If I discover that, I'll post it here.

Re: Line numbers not scrolling in script editor

Posted: Thu Sep 20, 2018 4:12 am
by FourthWorld
I have seen this recently. Have you filled a report? I can add some notes to it wheni I pin down the recipe.