difference in script editor, missing a few pixels and a crash

If you find an issue in LiveCode but are having difficulty pinning down a reliable recipe or want to sanity-check your findings with others, this is the place.

Please have one thread per issue, and try to summarize the issue concisely in the thread title so others can find related issues here.

Moderators: heatherlaine, Klaus, FourthWorld, robinmiller, kevinmiller

Post Reply
sphere
Posts: 621
Joined: Sat Sep 27, 2014 10:32 am
Location: the Netherlands

difference in script editor, missing a few pixels and a crash

Post by sphere » Mon Mar 19, 2018 7:32 pm

Hi,
anyone has this issue too?
The character 1 is missing a few pixels in the right upper corner.
This is lc9rc1
pixelsmissing.PNG
scripteditor in lc9rc1
pixelsmissing.PNG (2.23 KiB) Viewed 439 times
this is lc819
1inlc819.PNG
scripteditor in lc819
1inlc819.PNG (1.56 KiB) Viewed 439 times
i see also differences in thickness while the same font and size is used.


second thingy
Also had 3 times a crash which i could exactly replicate those 3 times and after that no more...
turned messages off-->i opened a stack-->got an error in script (which LC throwed up when opening the stack) -->open script-->i saw that End openStack was in the wrong place (it was caused by creating a new handler while hitting the return key)-->then wanted to copy/paste that line, i selected it and then hit CTRL-X-->LC9rc1 crashed

After this i repeated it a few times to be able to write it down for a bug report, but after the 3rd or 4th time it did not crash anymore, so...

regards,
Sphere
Please, stop quoting things my brother did not say. Thank you. Hans Zweistein.

bogs
Posts: 1817
Joined: Sat Feb 25, 2017 10:45 pm

Re: difference in script editor, missing a few pixels and a crash

Post by bogs » Tue Mar 20, 2018 3:30 am

I haven't noticed any chopped off tops on this machine (sparky linux, debian testing), but I do see other ... weirdness when using the SE.

When I set the color to custard in the preferences, for instance, it looks more like pinkish. If I type rapidly, which is most of the time, it seems like it falls behind quite a bit. The abnormal looking text I get, but bumping the size to 13 or 14 seems to fix that here (font: free sans). I definitely don't care for the sourcecode pro font it defaulted to :P :P
Image

sphere
Posts: 621
Joined: Sat Sep 27, 2014 10:32 am
Location: the Netherlands

Re: difference in script editor, missing a few pixels and a crash

Post by sphere » Tue Mar 20, 2018 7:08 pm

Thanks bogs, i will create a bug report
Please, stop quoting things my brother did not say. Thank you. Hans Zweistein.

bogs
Posts: 1817
Joined: Sat Feb 25, 2017 10:45 pm

Re: difference in script editor, missing a few pixels and a crash

Post by bogs » Tue Mar 20, 2018 7:25 pm

No problems. Love your sig by the way :D

Hint: you may want to switch the 'c' and 'i' below :)
...not mentioning the startup speed, whcih we now have again with SSD :D
Image

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 5962
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: difference in script editor, missing a few pixels and a crash

Post by FourthWorld » Tue Mar 20, 2018 7:46 pm

I wonder if this issue is perhaps somehow related to the text rendering change needed to accommodate this:
http://quality.livecode.com/show_bug.cgi?id=20856
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

bogs
Posts: 1817
Joined: Sat Feb 25, 2017 10:45 pm

Re: difference in script editor, missing a few pixels and a crash

Post by bogs » Tue Mar 20, 2018 8:33 pm

Could be? Was a bit out of my level.
Image

sphere
Posts: 621
Joined: Sat Sep 27, 2014 10:32 am
Location: the Netherlands

Re: difference in script editor, missing a few pixels and a crash

Post by sphere » Tue Mar 20, 2018 9:18 pm

Thanks Bogs, glad you like it :)

@ Richard, i don't know for sure if it is the same, looks a bit like it.
Those little screenshots where taken on Win10

And these 2 are taken on Mac (well that is...Hackintosh)
lc9rc1
lc9rc1onmac.png
lc9rc1onmac
lc9rc1onmac.png (16.27 KiB) Viewed 380 times
and lc819
lc819onmac.png
lc819onmac
lc819onmac.png (14.36 KiB) Viewed 380 times
did not change any default text setting
Please, stop quoting things my brother did not say. Thank you. Hans Zweistein.

bogs
Posts: 1817
Joined: Sat Feb 25, 2017 10:45 pm

Re: difference in script editor, missing a few pixels and a crash

Post by bogs » Tue Mar 20, 2018 9:57 pm

I have 2 questions, whats the default font on the one that is messing up, and what happens if you change the default font to a different one?

From what that bug report said (if I understood it correctly) this mostly affected one kind of font, skia(?).
Image

sphere
Posts: 621
Joined: Sat Sep 27, 2014 10:32 am
Location: the Netherlands

Re: difference in script editor, missing a few pixels and a crash

Post by sphere » Tue Mar 20, 2018 10:09 pm

it de faults to..Default
but it seems to be Source Code Pro 12
on size 13 and bigger it's ok

I know it's a storm in a glass of water,
but strange (or not)so different on the script editor in the lc versions
Please, stop quoting things my brother did not say. Thank you. Hans Zweistein.

bogs
Posts: 1817
Joined: Sat Feb 25, 2017 10:45 pm

Re: difference in script editor, missing a few pixels and a crash

Post by bogs » Tue Mar 20, 2018 10:35 pm

No, I agree with you, that source code pro font leaves a lot to be desired. I actually prefer comic sans myself a lot, reminds me of Calvin and Hobbes :mrgreen:
Image

monte
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 1559
Joined: Fri Jan 13, 2012 1:47 am
Contact:

Re: difference in script editor, missing a few pixels and a crash

Post by monte » Wed Mar 21, 2018 12:33 am

Hi Folks

Yes source code pro is now used as the default script editor font. Using a monospaced font in the script editor can make a significant difference to performance so we decided to bundle an open source font designed for coding to be the default. You can of course change this to whatever you want.

As far as the missing pixels goes that does look quite odd so thanks for the report!
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

sphere
Posts: 621
Joined: Sat Sep 27, 2014 10:32 am
Location: the Netherlands

Re: difference in script editor, missing a few pixels and a crash

Post by sphere » Wed Mar 21, 2018 1:00 pm

Thanks Monte !
Please, stop quoting things my brother did not say. Thank you. Hans Zweistein.

Post Reply

Return to “Bug Triage”