Search found 88 matches

by PBH
Mon Jul 21, 2014 1:58 am
Forum: Getting Started with LiveCode - Experienced Developers
Topic: Dropping coloured text on a field
Replies: 7
Views: 1790

Re: Dropping coloured text on a field

Andy, This works for me for dragging coloured text from a PDF into a LC field… --Field Script on dragEnter if the dragData["rtf"] is not empty then set the dragAction to "copy" -- Shows the drag copy cursor end if end dragEnter on dragDrop if the dragData["rtf"] is not empty then set the rtfText of ...
by PBH
Thu Jun 19, 2014 2:39 am
Forum: Getting Started with LiveCode - Experienced Developers
Topic: Find/Replace removes text style
Replies: 2
Views: 777

Re: Find/Replace removes text style

Sefro, There is a note about this behaviour in the dictionary, so it's not seen as a bug. Here's the note… Important! You can use the replace command on a field, but doing so removes any formatting (fonts, styles, colors, and sizes) in the field. To work around this limitation, use the field's htmlT...
by PBH
Fri May 02, 2014 5:35 am
Forum: Getting Started with LiveCode - Experienced Developers
Topic: Make Icon in Button appear to the left of text?
Replies: 6
Views: 2398

Re: Make Icon in Button appear to the left of text?

Hi Chris, If I understand this correct, it looks like this should be scriptable fairly easily, it just involves a little simple maths with the margin values. Tried this in a 300 px wide button… Apply the icon & set the label for the button then in the Property Inspector set the text to left align an...
by PBH
Thu Mar 27, 2014 5:21 am
Forum: MobGUI
Topic: MobGUI & LC 7.0(dp1) crash.
Replies: 3
Views: 1610

Re: MobGUI & LC 7.0(dp1) crash.

Thanks for the reply. I've tried starting MobGUI with Suppress Messages and Errors on, but that made no difference. Not sure there's anything else much I could try, it seems the crash happens as soon as the stack begins to load so it never becomes visible. Hope it doesn't cause you too much headache...
by PBH
Tue Mar 25, 2014 5:44 pm
Forum: MobGUI
Topic: MobGUI & LC 7.0(dp1) crash.
Replies: 3
Views: 1610

MobGUI & LC 7.0(dp1) crash.

Just tried launching MobGUI_V1-24.livecode with LC 7.0(dp1) on Mac OS X 10.8.5 and it just crashes straight away, has anybody else tried this?

Paul
by PBH
Fri Mar 21, 2014 2:28 am
Forum: Getting Started with LiveCode - Experienced Developers
Topic: Why are scripts running in edit mode
Replies: 1
Views: 558

Re: Why are scripts running in edit mode

Hi Sjat, You can turn off "Messages" in the toolbar (at the top of the screen) to stop any scripts from processing while you are working, alternatively go to Development>Suppress messages in the menus, but of course you will need to remember to turn them back on again to test your stacks in the IDE....
by PBH
Tue Mar 11, 2014 1:40 am
Forum: Windows
Topic: Getting scrollbars to work in a specific way
Replies: 4
Views: 1572

Re: Getting scrollbars to work in a specific way

Hi Mills, If I understood you correctly the attached stack should work OK. Basically I separated the controls into three groups, one main group for the grid, one group for the buttons and one group for the fields. I added graphic boxes to the button and field groups to make their size match the main...
by PBH
Sat Mar 08, 2014 3:48 am
Forum: Mac OS
Topic: Window loses focus when printing as sheet
Replies: 4
Views: 1710

Re: Window loses focus when printing as sheet

Terry,

The script works for me on Mac OSX 10.8.5 with LC 6.5.2

Have you tried stepping through your script with the debugger using breakpoints to see where it loses focus?

Paul
by PBH
Thu Jan 16, 2014 11:41 pm
Forum: Off-Topic
Topic: mouseColor
Replies: 4
Views: 2032

Re: mouseColor

Richmond, this is what I have found so far: Not working: Win 7 (under Parallels 8) / LC6.5.1 - mouseColor reports "0,0,0" regardless of the colour under the mouse pointer. Almost working: Mac OS X 10.8.5 / LC 6.5.1 (rc2) - mouseColor reports the "Display Native Values" (or screen colour) of whatever...
by PBH
Wed Jan 01, 2014 2:05 am
Forum: Talking LiveCode
Topic: Export snapshot and player..
Replies: 5
Views: 1090

Re: Export snapshot and player..

Hi Herman, No problem, I do realise that people can have very different experiences with software, even on what appears to be very similar systems. I did do extensive testing before submitting the bug report including testing different file formats, as I always do, but that doesn't mean I was able t...
by PBH
Tue Dec 31, 2013 7:31 pm
Forum: Talking LiveCode
Topic: Export snapshot and player..
Replies: 5
Views: 1090

Re: Export snapshot and player..

On Mac the problem is simply the file path to export to (tested snapshots on diff MacOS versions, also from player objects): There is no problem with import snapshot There is no problem with export snapshot IF => EITHER one exports to an existing image in current stack (create for example img "tmp"...
by PBH
Tue Dec 31, 2013 5:33 am
Forum: Talking LiveCode
Topic: Export snapshot and player..
Replies: 5
Views: 1090

Re: Export snapshot and player..

I ran into this problem recently and have filed a bug report. Depending on how your stack is set up you may be able to use the following workaround… on snapShotWorkAround -- Temporary Workaround for SnapShot fail in LC 6.5.x lock screen put the rect of player "myPlayer" into tRect import snapShot fr...
by PBH
Sat Jun 29, 2013 1:53 am
Forum: Extending LiveCode
Topic: Start of a date handling library
Replies: 33
Views: 14876

Re: Start of a date handling library

Thown out the extra button and it works great.

Thank you very much for sharing. :-)

Paul
by PBH
Sat Jun 29, 2013 1:32 am
Forum: Mac OS
Topic: Anoying editing problem
Replies: 8
Views: 3125

Re: Anoying editing problem

Working on Mac OS X 10.7.5 and 10.6.8 with LC 5.5.5/6.1 and I don't see this problem at all. I think I recall somebody (possibly Richmond) saying there was an issue with one of the early LC 6.0 releases, so updating your install may resolve the problem. http://forums.runrev.com/viewforum.php?f=4 Paul
by PBH
Sun May 05, 2013 2:03 am
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Question on preOpenCard hilitedbutton
Replies: 13
Views: 1652

Re: Question on preOpenCard hilitedbutton

Shawn,

There is a 'closeStack' message available too. You can use this to add clean-up stuff if necessary.

Is this just a problem in the IDE or do you have the same issue when you build a standalone?

Paul

Go to advanced search