Search found 72 matches

by Kevin
Wed Mar 02, 2011 4:16 pm
Forum: Rich Media
Topic: Basic UI elements.
Replies: 1
Views: 1101

Basic UI elements.

I would like to alter the theme of basic components removing most of the "chrome". A example would be Microsoft Metro theme or the example URL listed below. I am aware I can create my own controls the problem is I want all the basic control to utilize the theme is this even possible? Can I register ...
by Kevin
Wed Dec 22, 2010 3:52 pm
Forum: Linux
Topic: Linux Requirements.
Replies: 17
Views: 7041

Re: Linux Requirements.

Play by play: Most of the usage of my particular application is remote (X secession, VNC) the current server would be considered a antique as would the Linux installation (using Runtime Revolution 2.x). Recently, it has been requested that I add features and upgrade the server consider the multitude...
by Kevin
Wed Dec 22, 2010 2:44 pm
Forum: Linux
Topic: Linux Requirements.
Replies: 17
Views: 7041

Re: Linux Requirements.

http://www.justuni.org/~kevinw/Screenshot-Untitled1.png Compaq DL 360 running CentOS 5 32-bit installation No compositing window manager GTK/GDK/GLIB Pango/XFT LCMS GKSU MPLAYER ESD Screen shot from second LiveCode 4.5.2. Stack is simple drag controls from "Tool" window to "Main Stack" build as sta...
by Kevin
Tue Dec 21, 2010 8:40 pm
Forum: Linux
Topic: Linux Requirements.
Replies: 17
Views: 7041

Re: Linux Requirements.

Here is the error log should someone require it. Unable to get 32-bit visual, not using XFT (<unknown>:20501): Gdk-CRITICAL **: gdk_colormap_new: assertion `GDK_IS_VISUAL (visual)' failed (<unknown>:20501): Gtk-CRITICAL **: gtk_widget_set_colormap: assertion `GDK_IS_COLORMAP (colormap)' failed (<unk...
by Kevin
Tue Dec 21, 2010 8:37 pm
Forum: Linux
Topic: Linux Requirements.
Replies: 17
Views: 7041

Re: Linux Requirements.

I have just downloaded the most recent copy of LiveCode authorized it and "recompiled" (version 4.5.2 build 1150). The workbench stack is still producing black rectangles where buttons and etc, should be. I am unable to require users utilize a specific Linux distro especially require they have Compi...
by Kevin
Tue Dec 21, 2010 3:08 pm
Forum: Linux
Topic: Linux Requirements.
Replies: 17
Views: 7041

Re: Linux Requirements.

I am running CentOS 5.5 32-bit and Runtime Revolution 4.5. As for having a monologue my many personalities take um-bridge. :) )
by Kevin
Mon Dec 20, 2010 11:39 pm
Forum: Linux
Topic: Linux Requirements.
Replies: 17
Views: 7041

Re: Linux Requirements.

FYI: I first noticed this issue back in 3.x but never really had the copious spare time to investigate it throughly.

Kevin
by Kevin
Mon Dec 20, 2010 11:38 pm
Forum: Linux
Topic: Linux Requirements.
Replies: 17
Views: 7041

Re: Linux Requirements.

The answer is "Compositing window manager (optional - required for alpha-blended window shapes)". This should be NOT optional my testing reveals that without this functionality many controls are useless rendering only a black object (rectangle). Is there a system variable/command line arguement to a...
by Kevin
Mon Dec 20, 2010 10:40 pm
Forum: Linux
Topic: Linux Requirements.
Replies: 17
Views: 7041

Re: Linux Requirements.

Found a simular listing at http://www.mail-archive.com/use-revolut ... 19128.html still looking for a solution.
by Kevin
Mon Dec 20, 2010 9:12 pm
Forum: Linux
Topic: Linux Requirements.
Replies: 17
Views: 7041

Re: Linux Requirements.

I executed my older standalones they operate as expected Combo Box has the "Drop Arrow" not a black button where the "Drop Arrow" should be. Any ideas? I am considering a upgrade for the Christmas holidays and "Time is running out.".

Kevin
by Kevin
Mon Dec 20, 2010 7:37 pm
Forum: Linux
Topic: Linux Requirements.
Replies: 17
Views: 7041

Re: Linux Requirements.

It is possible to return the Revolution controls to their simplest incarnation. Basically disable gradients, anti-aliasing etc.
by Kevin
Mon Dec 20, 2010 3:29 pm
Forum: Linux
Topic: Linux Requirements.
Replies: 17
Views: 7041

Re: Linux Requirements.

Here is the error output it may be helpful to someone more familiar with Runtime Revolution. Unable to get 32-bit visual, not using XFT (<unknown>:8846): Gdk-CRITICAL **: gdk_colormap_new: assertion `GDK_IS_VISUAL (visual)' failed (<unknown>:8846): Gtk-CRITICAL **: gtk_widget_set_colormap: assertion...
by Kevin
Mon Dec 20, 2010 3:24 pm
Forum: Linux
Topic: Linux Requirements.
Replies: 17
Views: 7041

Re: Linux Requirements.

Thanks! Should it be necessary to include GTK Extras, GTK VNC or any of the GTK libraries not other than the basic library itself? I have already installed Pango, Lcms, GKSU, mPlayer and esd although for my "Workbench" none of these libraries are required. Several of the controls are alpha-blended p...
by Kevin
Mon Dec 20, 2010 5:40 am
Forum: Linux
Topic: Linux Requirements.
Replies: 17
Views: 7041

Linux Requirements.

I recently downloaded RR demo "recompiled" a "Workbench" standalone application for Linux (it happens to be my only platform). I believe I have missed some new requirement since several controls are simply block boxes (they still operate just are black). The development environment is on a different...
by Kevin
Thu May 06, 2010 9:34 pm
Forum: Talking LiveCode
Topic: User Interface.
Replies: 8
Views: 1912

Re: User Interface.

I appreciate all the assistance and will keep moving along trying different interfaces to see what is a success with my users.

Kevin

Go to advanced search