Search found 84 matches

by Peter Wood
Thu Apr 09, 2015 2:41 pm
Forum: CGIs and the Server
Topic: Put RSA key into variable
Replies: 2
Views: 1498

Re: Put RSA key into variable

The LiveCode dictionary says that the keys should be in pem format and shows how to create then using openSSL. I successfully tried this code: #!livecode if the environment is "server" and the platform is "MacOS" then set the outputLineEndings to "lf" set the outputTextEncoding to "utf8" end if[code...
by Peter Wood
Thu Apr 09, 2015 1:58 pm
Forum: LiveCode Builder
Topic: How to find out what is in a default library?
Replies: 5
Views: 1536

Re: How to find out what is in a default library?

Many thanks Ali.

I suspect that the issue I faced with min was that I didn't add

Code: Select all

use com.livecode.math
to the widget. I didn't think it was needed as the docs referred to it as a "default" library.
by Peter Wood
Thu Apr 09, 2015 6:47 am
Forum: LiveCode Builder
Topic: The Pink Circle Example
Replies: 8
Views: 2275

Re: The Pink Circle Example

I can only answer by experimenting. It seems the public keyword is necessary. When I removed it from the onPaint handler, the code compiles but the widget doesn't display anything.

By the way, I am using the 8.0 DP 1 release.
by Peter Wood
Thu Apr 09, 2015 6:38 am
Forum: LiveCode Builder
Topic: How to find out what is in a default library?
Replies: 5
Views: 1536

How to find out what is in a default library?

I tried to use the min function in LiveCodeBuilder thinking that it could be in the default com.livecode.math library. It wasn't, well not in the form that I tried to use - min(Real, Real). So I tried unsuccessfully to find the code of the library in GitHub. Is there any easy way to find out the API...
by Peter Wood
Thu Apr 09, 2015 6:32 am
Forum: LiveCode Builder
Topic: The Pink Circle Example
Replies: 8
Views: 2275

The Pink Circle Example

As well as the choice of colour, I found one "real" issues and a couple of other annoynances with the pink circle example. The issue is the example uses "real" instead of "Real" which causes a compilation error. The first annoyance is the radius of the circle is set to the width of the widget so it ...
by Peter Wood
Thu Mar 19, 2015 11:04 pm
Forum: LiveCode Builder
Topic: LiveCode Builder Test Framework
Replies: 2
Views: 1047

Re: LiveCode Builder Test Framework

That's great news.
by Peter Wood
Thu Mar 19, 2015 11:52 am
Forum: LiveCode Builder
Topic: LiveCode Builder Test Framework
Replies: 2
Views: 1047

LiveCode Builder Test Framework

From a quick look at the tests in Github, the LiveCode Builder Test Framework looks good. From its implementation, especially the test runner, it seems that it has been developed for testing LiveCode Builder itself. Is it possible for the test "dialect" to be made available via the extension manager...
by Peter Wood
Thu Mar 19, 2015 10:03 am
Forum: LiveCode Builder
Topic: Are there examples of extensions?
Replies: 7
Views: 1602

Re: Are there examples of extensions?

@Mark Many thanks for the clear and comprehensive explanation. The approach makes a lot of sense.
by Peter Wood
Thu Mar 19, 2015 7:03 am
Forum: LiveCode Builder
Topic: Are there examples of extensions?
Replies: 7
Views: 1602

Re: Are there examples of extensions?

@Trevor I notice that you use the "identifier" community.livecode.trevordevore in your extension. Is it standard to use community.livecode? I was wondering if, given that anybody with a commercial subscription is eligible for an @livecode.org address, it would be good to use org.livecode as the stan...
by Peter Wood
Thu Mar 05, 2015 12:55 pm
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Windows 7 LiveCode Server Error Setup Issue
Replies: 18
Views: 4279

Re: Windows 7 LiveCode Server Error Setup Issue

livecodeserver.exe needs to be in the cgi-bin folder

test.lc needs to be in the document root folder
by Peter Wood
Tue Mar 03, 2015 3:20 am
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Windows 7 LiveCode Server Error Setup Issue
Replies: 18
Views: 4279

Re: Windows 7 LiveCode Server Error Setup Issue

I suspect the root of the problem may be that the LiveCode lesson was written some time ago and most likely were for Apache 2.2. I'm guessing that the current WAMP installation is of Apache 2.4 First thing to check is whether the three Apache modules needed to use LiveCode pages are enabled. They ar...
by Peter Wood
Sun Mar 01, 2015 10:02 am
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Windows 7 LiveCode Server Error Setup Issue
Replies: 18
Views: 4279

Re: Windows 7 LiveCode Server Error Setup Issue

From the error message it looks as though the problem is that the Action directive is inside the <Directory> tag. I has assumed you would move it when you moved the AddHander directive. Sorry. Try moving the Action directive after the AddHandler.
by Peter Wood
Fri Feb 27, 2015 1:30 am
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Windows 7 LiveCode Server Error Setup Issue
Replies: 18
Views: 4279

Re: Windows 7 LiveCode Server Error Setup Issue

A couple of points about your configuration file: 1. I'm not sure that the AddHandler directive can be included within <Directory> tags. Try putting it just before your ScriptAlias directive. 2. You have used / for the htdocs directory and \ for the cgi-bin directory 3. "cgi-bin" in your Script Alia...
by Peter Wood
Sun Feb 22, 2015 11:26 am
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Windows 7 LiveCode Server Error Setup Issue
Replies: 18
Views: 4279

Re: Windows 7 LiveCode Server Error Setup Issue

Your Script Alias entry in the Apache configuration file may not be correct. I think the parameters should be directories not files. Try this instead: ScriptAlias /livecode-cgi/ "C:\Program Files (x86)\Apache Software Foundation\Apache2.2\htdocs\livecode-cgi\" If that doesn't work perhaps you could ...
by Peter Wood
Sun Feb 15, 2015 12:14 am
Forum: Getting Started with LiveCode - Complete Beginners
Topic: LiveCode Server Setup Issue
Replies: 2
Views: 599

Re: LiveCode Server Setup Issue

I'm guessing from the filenames that you are trying to install LiveCode Server on Windows. It seems that you have two definitions of <Directory "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs">. Also this line: Action livecode-script /livecode-cgi/livecode-server.exe You specify ...

Go to advanced search