Search found 65 matches

by Tukcedo
Tue Sep 02, 2014 8:21 pm
Forum: Getting Started with LiveCode - Complete Beginners
Topic: First card with visual effect not accessible (SOLVED)
Replies: 9
Views: 1601

First card with visual effect not accessible (SOLVED)

Coders, here's another peculiar thing I noticed: I'm trying to create some sort of a splash screen by placing an image on the first card using the same background as the rest and then jump to the next card after a set delay using visual effect: on openCard visual effect dissolve wait 3 seconds go to...
by Tukcedo
Tue Sep 02, 2014 8:09 pm
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Rescaling a selected image from album on Android
Replies: 19
Views: 3601

Re: Rescaling a selected image from album on Android

First the good news: the delete now works and it fixes the situation of overlapping or non-resizing images. Left to do: Android reverses portrait and landscape (i.e. camera landscape = image portrait) Hmmm don't think so: I'm getting different results for the "preferences" and the "variable checking...
by Tukcedo
Tue Sep 02, 2014 10:46 am
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Rescaling a selected image from album on Android
Replies: 19
Views: 3601

Re: Rescaling a selected image from album on Android

[Sigh] You old pirate you ;-) ;-)

Would strict checking catch this, as it does in Perl and other lingoes?
by Tukcedo
Tue Sep 02, 2014 6:20 am
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Rescaling a selected image from album on Android
Replies: 19
Views: 3601

Re: Rescaling a selected image from album on Android

Hmmm another hint please Simon? I'm following the pattern in the language directory for the delete command where it says" delete button "New Button" And similarly for exists: exists(button "OK" of card "Preferences") I could add the card name of course, but since I'm on the card where the image sits...
by Tukcedo
Mon Sep 01, 2014 10:15 pm
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Rescaling a selected image from album on Android
Replies: 19
Views: 3601

Re: Rescaling a selected image from album on Android

Eureka! We're really ALMOST there now ... Thanks Simon for leaving the double quotes exercise to the reader ;-) Most instructive! ALMOST, because I still have the strange effect that when the phone is held "portrait" it produces a "landscape" image and vice versa. This results in a landscape image b...
by Tukcedo
Sun Aug 31, 2014 9:34 pm
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Rescaling a selected image from album on Android
Replies: 19
Views: 3601

Re: Rescaling a selected image from album on Android

Followed Jacque's comments about lockloc (tried lockLoc too, the naming convention suggests that's how it should be written, right?) and the order of changing size and position. I'm now consistently getting the selected image taking up the entire screen, hence can't get to any of my buttons. Am I ge...
by Tukcedo
Sun Aug 31, 2014 5:26 pm
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Rescaling a selected image from album on Android
Replies: 19
Views: 3601

Re: Rescaling a selected image from album on Android

:D that brought a smile to my face, that I'm not the only one getting confused on the old double quotes every now and then! However, even the lockLoc doesn't always result in the correct behaviour, hence my confusion. I know I'm doing something wrong somewhere but (obviously) haven't figured out wha...
by Tukcedo
Sat Aug 30, 2014 9:58 pm
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Rescaling a selected image from album on Android
Replies: 19
Views: 3601

Re: Rescaling a selected image from album on Android

Thanks a lot Simon. That gave me lots of ideas to play with tonight ;-) Unfortunately I'm afraid my knowledge of LC is probably not yet up this sort of level .. The strange thing is that the results seem a bit erratic. With the code below I get a full screen of part of the image but no resize and no...
by Tukcedo
Fri Aug 29, 2014 9:16 pm
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Rescaling a selected image from album on Android
Replies: 19
Views: 3601

Rescaling a selected image from album on Android

LiveCoders, I've been struggling with the various code snippets that I found here and elsewhere on internet, but don't think I understand where exactly my problem lies. I've tried to follow this lesson: http://lessons.runrev.com/m/4069/l/11489-how-do-i-get-an-image-from-my-mobile-photo-library and a...
by Tukcedo
Tue Aug 26, 2014 10:17 am
Forum: Android Deployment
Topic: Unable to build app for testing...
Replies: 5
Views: 2099

Re: Unable to build app for testing...

I work on Linux and there the logcat command is something like: sudo /home/<user>/<path_to_adb>/adb logcat The sudo is because otherwise I can't get adb to "see" my Android (it displays "???????? Android" in adb devices). This however produces tons of messages on your screen so I use a few tricks: s...
by Tukcedo
Wed Aug 20, 2014 12:41 pm
Forum: Android Deployment
Topic: Unable to build app for testing...
Replies: 5
Views: 2099

Re: Unable to build app for testing...

Did you try to capture error messages with Logcat? It's an option to the adb program that you also use to set up the USB connection to the Android device (at least it is on my Ubuntu laptop). Personally I found a bug when you try to use SQLite under Android, also under Ubuntu.
by Tukcedo
Thu Aug 14, 2014 9:41 pm
Forum: Android Deployment
Topic: APK builds and installs but won't run
Replies: 14
Views: 2494

Re: APK builds and installs but won't run

Tried that too just now, no luck ...
by Tukcedo
Thu Aug 14, 2014 5:54 pm
Forum: Android Deployment
Topic: APK builds and installs but won't run
Replies: 14
Views: 2494

Re: APK builds and installs but won't run

Hmmm I changed the path to "documents" but as soon as I use the SQLite checkbutton it bombs out again. Did a filter on *.E and name of my Identifier and then I believe the below is the culprit: E/dalvikvm( 8134): dlopen("/data/app-lib/nl.tukcedo.war-2/librevdb.so") failed: dlopen failed: "/data/app-...
by Tukcedo
Thu Aug 14, 2014 12:01 pm
Forum: Android Deployment
Topic: APK builds and installs but won't run
Replies: 14
Views: 2494

Re: APK builds and installs but won't run

Thanks Simon, that may be the problem then as I had them located in "Home"! Incidentally, you also answered a question I had about how to distribute a database along with the package. I'll give it another try later.

Go to advanced search