Search found 107 matches

by stephenmcnutt
Sat Nov 03, 2018 7:33 pm
Forum: Talking LiveCode
Topic: Why tsNet.bundle?
Replies: 8
Views: 483

Re: Why tsNet.bundle?

Thank you very much, Charles. That did the trick. No more BundleIdentifier collision when uploading app to Mac App store with Xcode's Application Loader.

Now, has anyone reported this as a bug or whatever needs to be done to ensure it's fixed?
by stephenmcnutt
Mon Oct 22, 2018 10:34 pm
Forum: Talking LiveCode
Topic: Why tsNet.bundle?
Replies: 8
Views: 483

Re: Why tsNet.bundle?

I can't seem to make it stop including tsNet.bundle. I've replaced the put URL commands with revCopyFile commands and searched my script to make sure all instances of the word URL are gone. Yet the standalone builder keeps including tsNet.bundle. There are really two problems. I'd like to solve both...
by stephenmcnutt
Tue Oct 09, 2018 10:36 pm
Forum: Talking LiveCode
Topic: Why tsNet.bundle?
Replies: 8
Views: 483

Re: Why tsNet.bundle?

Yes, my code does use URLs for copying some local files. Example... put URL ("binfile:" & gMacPackageFilePath_Settings_Saver) into URL ("binfile:" & gMacLibraryFilePath_Settings_Saver) The only reason I resorted to this URL business is because whatever "normal" command, probably "copy" wasn't workin...
by stephenmcnutt
Tue Oct 09, 2018 10:22 pm
Forum: Talking LiveCode
Topic: Answer Dialogs Not Working in Standalone
Replies: 21
Views: 667

Re: Answer Dialogs Not Working in Standalone

What is remote debugging?
by stephenmcnutt
Mon Oct 08, 2018 11:12 pm
Forum: Talking LiveCode
Topic: Answer Dialogs Not Working in Standalone
Replies: 21
Views: 667

Re: Answer Dialogs Not Working in Standalone

Should I do a bug report then? If so, where do I do that?
by stephenmcnutt
Sun Oct 07, 2018 9:51 pm
Forum: Talking LiveCode
Topic: Answer Dialogs Not Working in Standalone
Replies: 21
Views: 667

Re: Answer Dialogs Not Working in Standalone

I can confirm some of the above. When I choose to manually select inclusions, three are automatically pre-selected (cursors, answer dialog, and ask dialog), and at least the answer and ask dialogs can't really be deselected as they're re-selected automatically next time you look. When I do manual se...
by stephenmcnutt
Sun Oct 07, 2018 1:30 am
Forum: Talking LiveCode
Topic: Why tsNet.bundle?
Replies: 8
Views: 483

Re: Why tsNet.bundle?

LC 9.0.1, latest Xcode (just downloaded it today)

I'm letting it figure out the inclusions, but I guess I should select them manually.
by stephenmcnutt
Sat Oct 06, 2018 10:23 pm
Forum: Talking LiveCode
Topic: Why tsNet.bundle?
Replies: 8
Views: 483

Why tsNet.bundle?

I guess I have three related questions, found at the end of the following three paragraphs... When my standalone is built, tsNet.bundle gets included in one of the Externals folders. This tsNet thing is for Internet functionality, right? My app in no way accesses the Internet. I don't know what migh...
by stephenmcnutt
Sat Oct 06, 2018 5:37 pm
Forum: Talking LiveCode
Topic: Answer Dialogs Not Working in Standalone
Replies: 21
Views: 667

Re: Answer Dialogs Not Working in Standalone

Nice detective work! I don't know if that indicates LC or macOS, but it's doubtless a clue.

Yeah I wansn't keen on reinstalling macOS, either, but I hadn't erased the drive since I bought the machine since I bought it five years ago. No telling what kind of scum had accumulated.
by stephenmcnutt
Fri Oct 05, 2018 5:18 pm
Forum: Talking LiveCode
Topic: Answer Dialogs Not Working in Standalone
Replies: 21
Views: 667

Re: Answer Dialogs Not Working in Standalone

Doing a clean re-install of macOS did the trick. I suspect completely uninstalling and reinstalling LiveCode might have fixed the problem, too.
by stephenmcnutt
Thu Oct 04, 2018 4:35 pm
Forum: Talking LiveCode
Topic: Answer Dialogs Not Working in Standalone
Replies: 21
Views: 667

Re: Answer Dialogs Not Working in Standalone

Thanks, Klaus. You've been a huge help over the years. I was hoping it would be something simple (for me) like a flaw in 9.0.1, but, like you said, it seems to be on my end. I haven't done a clean OS install in years, so I think I might do that--just start over with everything and see what's up. I m...
by stephenmcnutt
Wed Oct 03, 2018 10:04 pm
Forum: Talking LiveCode
Topic: Answer Dialogs Not Working in Standalone
Replies: 21
Views: 667

Re: Answer Dialogs Not Working in Standalone

I've never added any inclusions manually before, but this sounds like a likely solution. No. Just checked, and I've got "Search for required inclusions..." selected.
by stephenmcnutt
Wed Oct 03, 2018 9:26 pm
Forum: Talking LiveCode
Topic: Answer Dialogs Not Working in Standalone
Replies: 21
Views: 667

Answer Dialogs Not Working in Standalone

In 9.0.1, My "answer" dialog boxes don't appear after the app is made into a macOS standalone. Example... answer "Hi there" as sheet or answer "Hi there" Both work fine in the IDE but not in the standalone. The sheet or dialog box never appears, and code execution for that handler stops. Well, maybe...
by stephenmcnutt
Mon Sep 04, 2017 10:09 pm
Forum: Mac OS
Topic: tsNet and CFBundleIdentifier Collision Error - Mac App Store
Replies: 1
Views: 945

tsNet and CFBundleIdentifier Collision Error - Mac App Store

When attempting to upload my signed package to iTunes Connect (Mac App Store) with Apple's Application Loader, I got this error: ERROR ITMS-90511: "CFBundleIdentifier Collision. The Info.plist CFBundleIdentifier value 'au.com.techstrategies.external.tsNet' of 'Classroom Quizshow.app/Contents/MacOS/E...
by stephenmcnutt
Sun Sep 03, 2017 4:55 pm
Forum: Mac OS
Topic: Can't copy data files into sandboxed app's container
Replies: 9
Views: 1349

Re: Can't copy data files into sandboxed app's container

Yes!!!! When I use the "put URL" method properly, including the file names in the second part as you suggested, it works in both the unsandboxed and sandboxed versions of my standalone. I'm back in business and moving forward after more than a year of stagnation! Thank you! So, lesson learned here i...

Go to advanced search