Search found 1738 matches

by SparkOut
Tue Jul 17, 2018 10:53 pm
Forum: Getting Started with LiveCode - Complete Beginners
Topic: No way to edit a script !
Replies: 11
Views: 452

Re: No way to edit a script !

I am getting something like this sometimes too. It's like the tools palette is not respecting the browser versus pointer mode, so if it's a button it gets clicked, not selected, and right-click doesn't bring up context menu.
And still the PB is forever disappearing
by SparkOut
Sun Jul 15, 2018 5:17 pm
Forum: Getting Started with LiveCode - Experienced Developers
Topic: About LiveCode
Replies: 12
Views: 271

Re: About LiveCode

I haven't been silent, I just haven't been able to get a reliable recipe to put on the bug list, which is the only place it will get serious attention. There are plenty of "general" bug listings like this there though. Survival has only been because using LiveCode is not my "day job". I know Windows...
by SparkOut
Sun Jul 15, 2018 8:31 am
Forum: Getting Started with LiveCode - Experienced Developers
Topic: About LiveCode
Replies: 12
Views: 271

Re: About LiveCode

Windows 10 LC 8 was completely unusable for me, and there have been large problems with LC 9 in the script editor. Sometimes I could be typing for 20 or 30 seconds with no visual change on screen. Then all the text appeared as if it had been pasted in. Copying and pasting script lines was a nightmar...
by SparkOut
Sat Jul 14, 2018 6:39 pm
Forum: Bug Triage
Topic: Graphic won't resize properly
Replies: 3
Views: 119

Re: Graphic won't resize properly

No resize handlers involved and no modifier keys either. It is disconcerting that it is not doing the same with a new blank stack. I have no idea what could be causing this behaviour in the stack under development. I will try and see if there is something that can be sent for analysis at the mothers...
by SparkOut
Sat Jul 14, 2018 3:48 pm
Forum: Bug Triage
Topic: Graphic won't resize properly
Replies: 3
Views: 119

Graphic won't resize properly

I have an issue (with some stacks) where if I add a graphic from the tools palette it won't let me resize it properly. The drag handles show against each edge or corner, but it won't let me expand in either X or Y dimension. If I drag from the corner it will force resize to be square only. Sometimes...
by SparkOut
Wed Jul 11, 2018 5:28 am
Forum: Talking LiveCode
Topic: [SOLVED] A ton of stacks got attached to my one stack - how do I get rid of them all?
Replies: 13
Views: 201

Re: A ton of stacks got attached to my one stack - how do I get rid of them all?

Do the names largely begin with "rev"? Have you got the show LiveCode stacks in IDE menu option ticked? Or whatever the wording is, but LC IDE is written in LC, so the IDE stacks are all accessible, but typically hidden from the lists and menus, so as to leave your view with only your project. They ...
by SparkOut
Fri Jun 29, 2018 7:48 am
Forum: LiveCode for FM
Topic: Execution Error: No Such Object
Replies: 6
Views: 462

Re: Execution Error: No Such Object

What happens in the checkWall and checkBox handlers? Do they check for a collision and delete the graphic if so? The graphic seems to have been deleted, so how do you handle exiting the loop? You send the handler again in 1. Maybe you should if "moveBallx" is not in the pendingMessages then send "mo...
by SparkOut
Mon Jun 25, 2018 3:57 pm
Forum: Android Deployment
Topic: Identifier folder not visible
Replies: 6
Views: 258

Re: Identifier folder not visible

specialFolderPath ("documents") is a sandboxed location on mobile. You would have to have your phone rooted to be able to use a file explorer to see it from anything other than your app. You should be able to test reading the file from within your app, or check if there is a file specialFolderPath (...
by SparkOut
Sun Jun 24, 2018 7:44 am
Forum: Bug Triage
Topic: Play (audioClip) delay / hang
Replies: 8
Views: 645

Re: Play (audioClip) delay / hang

Prepare doesn't help, and the issue remains whether using an audioClip or player. Any ideas?
by SparkOut
Fri Jun 22, 2018 6:54 am
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Replace pict in buttons
Replies: 2
Views: 106

Re: Replace pict in buttons

The picture on a button will be "the icon". This is referenced by a number, which is the id of the image you want to use. So if you import an image to a spare place in your stack that is not typically visible, you can check it in the property inspector and see its id, let's assume 27314. Then you ca...
by SparkOut
Wed Jun 20, 2018 11:06 pm
Forum: Getting Started with LiveCode - Experienced Developers
Topic: copying image acros stacks doesn't work on Mac
Replies: 14
Views: 281

Re: copying image acros stacks doesn't work on Mac

Yes! Get used to specialFolderPath("resources") - this is where you will find all files and folders included in the standalone settings. It works on all architectures and is intended to reference "resource" files for this exact reason. It is a read only location on most platforms. And loads of peopl...
by SparkOut
Wed Jun 20, 2018 9:49 pm
Forum: Getting Started with LiveCode - Experienced Developers
Topic: copying image acros stacks doesn't work on Mac
Replies: 14
Views: 281

Re: copying image acros stacks doesn't work on Mac

Also try "put the long id of <the image reference>" and/or "if there is an image <the image reference >" before you try to copy. You will hopefully get more clues as to what is wtong. If it works in the IDE but not the standalone then it is most likely either a relative path issue or a standalone in...
by SparkOut
Tue Jun 19, 2018 9:43 pm
Forum: Bug Triage
Topic: Play (audioClip) delay / hang
Replies: 8
Views: 645

Re: Play (audioClip) delay / hang

Haha, that's of old, I always think "jwack" the same as I can't help but say "Klausimausi" :)
by SparkOut
Tue Jun 19, 2018 7:26 pm
Forum: Bug Triage
Topic: Play (audioClip) delay / hang
Replies: 8
Views: 645

Re: Play (audioClip) delay / hang

Thanks jwack, I will test that as soon as I can
by SparkOut
Tue Jun 19, 2018 7:25 pm
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Having an issue using replace and Item number
Replies: 7
Views: 320

Re: Having an issue using replace and Item number

I doubt there would be any difference in measurable terms but you can eliminate the check for the empty temp var and just

Code: Select all

put tLine & cr after tempsortedxml
at the end just delete the last char to get rid of the trailing cr.

Go to advanced search