Search found 360 matches

by LiveCode_Panos
Sat Apr 21, 2018 10:38 pm
Forum: Getting Started with LiveCode - Experienced Developers
Topic: Package Appears To Be Corrupt
Replies: 4
Views: 63

Re: Package Appears To Be Corrupt

What happens if in the Android standalone settings you choose "sign for development only"?

Best
Panos
--
by LiveCode_Panos
Fri Apr 20, 2018 8:56 pm
Forum: iOS Deployment
Topic: several versions of a same app on App Store ?
Replies: 2
Views: 89

Re: several versions of a same app on App Store ?

Hi Jean Marc,

If you set the minimum deployment version (e.g. "iOS 8.0 or later") in the standalone settings, your app will be available to devices running iOS 8.0 or later. This is independent of the Xcode version you use to build the standalone.

Best,
Panos
--
by LiveCode_Panos
Wed Apr 18, 2018 12:12 pm
Forum: Getting Started with LiveCode - Experienced Developers
Topic: Standalone doesn't quit on first launch
Replies: 5
Views: 120

Re: Standalone doesn't quit on first launch

Hi Trevix,

Thanks for the follow up. Yes please, if you could file a bug and attach a sample stack it would be great.

If you only see that with your confidential stack, feel free to email it directly to panos.merakos at livecode dot com

Best,
Panos
--
by LiveCode_Panos
Tue Apr 17, 2018 3:55 pm
Forum: Getting Started with LiveCode - Experienced Developers
Topic: Standalone doesn't quit on first launch
Replies: 5
Views: 120

Re: Standalone doesn't quit on first launch

Hi Trevix,

Maybe a runtime error occurs in the IDE and it fails silently, causing the execution to stop (thus it does not quit).

try to <put true into grevdevelopment> and test again. If this is what happened, now the error will be thrown rather than failing silently.

Best,
Panos
--
by LiveCode_Panos
Tue Apr 17, 2018 1:26 pm
Forum: Android Deployment
Topic: black screen with LC9, ok with LC8.1.9
Replies: 8
Views: 315

Re: black screen with LC9, ok with LC8.1.9

Hi bangkok, Thank you for the update. OK, so it seems that there is something specific to this device that LC 9 does not like. We have done a lot of changes between LC 8 and 9, one of them is that we use a different version of the android toolchain to build the android engines. What are the specs of...
by LiveCode_Panos
Tue Apr 17, 2018 8:49 am
Forum: Android Deployment
Topic: black screen with LC9, ok with LC8.1.9
Replies: 8
Views: 315

Re: black screen with LC9, ok with LC8.1.9

Hi bangkok,

Thank you for the stack. I have tested on two Android devices (one running Android 8 and one running Android 5) and I cannot reproduce the problem.

What happens if you set the minimum Android version to 2.3.3 (in the Android Standalone Settings)?

Best,
Panos
--
by LiveCode_Panos
Mon Apr 16, 2018 4:00 pm
Forum: Mac OS
Topic: LC 9.0.0 Message Box does not appear when on breakpoint
Replies: 10
Views: 283

Re: LC 9.0.0 Message Box does not appear when on breakpoint

Hi adxsoft and bogs, Thank you for the follow up. Indeed, there is a bug here. It seems that in LC 9.0.0 the Script Editor traps the cmd+M keystroke, and this results in the the msg box not appearing if the Script Editor has the focus. I have filed this bug: https://quality.livecode.com/show_bug.cgi...
by LiveCode_Panos
Mon Apr 16, 2018 3:02 pm
Forum: Android Deployment
Topic: black screen with LC9, ok with LC8.1.9
Replies: 8
Views: 315

Re: black screen with LC9, ok with LC8.1.9

Hi all,

Works fine for me here.

@ bangkok
Could you attach the stack here? Moreover, what is the device you are using? Do you have access to a different device?

Best,
Panos
--
by LiveCode_Panos
Sat Apr 14, 2018 11:00 pm
Forum: Internet
Topic: Play audiofile from url to IOS
Replies: 2
Views: 211

Re: Play audiofile from url to IOS

Hi per_b,

If the URL is not https it will be blocked by ATS on iOS. Try disabling ATS in the standalone application settings.

Best,
Panos.
by LiveCode_Panos
Fri Apr 13, 2018 7:45 pm
Forum: iOS Deployment
Topic: JSONtoarray and JSONimport fail in iOS
Replies: 2
Views: 157

Re: JSONtoarray and JSONimport fail in iOS

Hi hutchfx, You should probably add the JSON Library and the mergJSON extension to the standalone: 1. In the General pane of the standalone settings choose "select inclusions for the standalone application" 2. In the Inclusions pane (which is now enabled) check "JSON Library" and "mergJSON". Hope th...
by LiveCode_Panos
Fri Apr 13, 2018 2:26 pm
Forum: iOS Deployment
Topic: Changes to uploading to Apple store
Replies: 2
Views: 97

Re: Changes to uploading to Apple store

Hi Matt,

The error probably means that something has gone wrong when packaging the .ipa file.

Please have a look at this bug report, the user had the same issue.

Best,
Panos
--

PS: Apple has changed the rules of App Store submission and they now *require* a .ipa file
by LiveCode_Panos
Thu Apr 12, 2018 3:32 pm
Forum: Mac OS
Topic: LC 9.0.0 Message Box does not appear when on breakpoint
Replies: 10
Views: 283

Re: LC 9.0.0 Message Box does not appear when on breakpoint

Hi adxsoft, I am not able to reproduce this bug here. I cannot find any menu with Message Window You should see the main LC menubar (Horizontal toolbar on top of the screen) even when you are on debug mode. Isn't this the case? Could you attach a screenshot of what you see (the whole screen if possi...
by LiveCode_Panos
Wed Apr 11, 2018 12:37 pm
Forum: Mac OS
Topic: LC 9.0.0 Message Box does not appear when on breakpoint
Replies: 10
Views: 283

Re: LC 9.0.0 Message Box does not appear when on breakpoint

Hi adxsoft,

Welcome to the forum.

Does that problem happen only when pressing cmd+M?
Does the message box appear if you click on the Message Box icon in the LC menubar?

Best,
Panos
--
by LiveCode_Panos
Mon Apr 09, 2018 5:08 pm
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Standalone Application, Xcode 9.2, Livecode 9.0.0
Replies: 3
Views: 127

Re: Standalone Application, Xcode 9.2, Livecode 9.0.0

Hi jmm123, Welcome to the forum. A rough guess is that you get that msg because the Xcode command line tools are not up to date. What does the following command return (type it in the terminal): xcode-select -p If it does not return a path to xcode9.2, you have to change it. Try this: 1. Open Xcode ...
by LiveCode_Panos
Sat Apr 07, 2018 2:41 pm
Forum: iOS Deployment
Topic: Simulator fails in LC 9 with 11.2, while 11.1 in Xcode 9.2
Replies: 4
Views: 259

Re: Simulator fails in LC 9 with 11.2, while 11.1 in Xcode 9.2

Hi all, For example, Xcode 9.2 is NOT able to mount an iOS iPad with iOS 11.3... This is not correct. There is a difference between the following two "iOS versions": 1. The version of the iOS *SDK* that is used to build the iOS standalone. This depends *only* on the Xcode version you are using to bu...

Go to advanced search